Peugeot Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi all, i have ordered myself an amplified FLI 10" sub from Bass Junkies and was wondering if anyone has installed one of these into their pug and if it is difficult to fit. I have a S reg 206 and have never fitted speakers into a car, i managed my HU without any problems and would like to fit my sub myself.

If anyone has fitted one, did you have any problems? is there any other equipment i might need like extra connections or cables etc?

Thanks in advance!!
 
G

·
Hi

Fitting a sub should be straight forward.

You have a couple of choices re location of the amp if its not screwed into the side of the sub.

You will need to run power cable from the battery to the amp - this is heavy cable - so dont use crappy thin cable - or it may melt. Ensure that the cable is thick enough to carry the current for the amp - check what fuses are in the amp, then add a bit for saftey margin and to prevent voltage drop. You also need an aux wire too, so that the amp will switch on when the ehngine is on, or the first click min.

Next, is how are you to connect it to the head unit? If you have an aftermarket head unit it may have a sub out.

If not, then you need to connect up probably your rear speakers. The best way to get to that signal is run speaker cable from the head unit to the boot (assuming the amp is there) and use high level inputs if your amp has them. If not, then you need an adapter high to low. I am assuming your amp has a low pass filter etc.


Questions? - fire away.

D
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top