Peugeot Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
I recently bought a 206 quicksilver and am very happy with it, except that the radio was broken (CD loading mechanism).

After I switched out the broken Clarion RD3 radio with some Blaupunkt radio/navigation/crap (from a Volkswagen Golf), i started getting problems. The radio works fine, and the car works fine too the first time I turn the ignition. But when i turn off the ignition and start the car a few minutes later the problems start:
  • all the dashboards lights go on
  • the "stop" light starts blinking
  • all needles/meters go to zero
  • the display indicates that dashboard airbag is disabled
  • the display backlight flickers every 20-30 seconds.
  • However: the radio works fine and the engine runs perfectly during this.

The problem can only be fixed by removing the radio and starting the car a 2nd time.

Does anybody know what could be causing this?
 

·
Registered
Joined
·
534 Posts
Just a guess but could it be that the car is expecting a Peugeot Radio, finding a Clarion and the BSI is throwing a fit?

The alternative might be that the resistance to earth in the Clarion is different from the standard.

Anyhoo, I think there's a Clarion Radio post somewhere if you have a search.
 

·
Registered
Joined
·
21 Posts
what year is your car mate? these cars dont take well to aftermarket stereos being fitted due to them having multiplex wiring. i went into halfords years ago and asked them to fit a stereo and they refused to do it for this reason. i believe there is a way u can fit an aftermarket stereo without having problems by fitting some sort of box behind the stereo. your peugeot dealer will be able to tell u all about it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top