Peugeot Forums banner

21 - 28 of 28 Posts

·
Registered
Joined
·
3 Posts
Hello, I have the same problem, Peugeot doesn’t find the problem and told me that’s the phone.
I live in France

did you find a solution ?
 

·
Registered
Joined
·
2 Posts
Hi, I live in the Netherlands and I had similar issues with my iPhone X and Peugeot 5008 RCC. Continuously restarting RCC as soon as it is connected with my phone via BT or CarPlay. Peugeot dealer told me it is because of my phone.

Now i have removed the MyPeugeot App from my phone and since then I don't have any problems. Seems to working fine with BT and CarPlay.

Removing MyPeugeot app solved my problem in my case.
 

·
Registered
Joined
·
26 Posts
I’m UK and have a 2017 allure model which started doing this yesterday and again today. No idea why and like said above, it stays on for ages, then reboots to that screen again. Can’t do anything with it. No sounds, press and hold various buttons does nothing, nothing in USB or the 12v. Gonna harass them dealer tomorrow.
[/QUOT

Hi what was the outcome from dealer.. mine is doing the same and I've been told I might have to pay myself to fix it. Thanks
 

·
Registered
Joined
·
2 Posts
Car went into the Peugeot Dealership two weeks ago where they did the firmware update under warranty (out of warranty this seems to cost about £60) and the next day, started doing it again so I going.

Like people have said above - think it’s the iPhone linking that seems to be the issue but whether I have Bluetooth on or not doesn’t seem to make any difference, I have latest IOS firmware, not using as a hotspot. I’m gonna try the remove Peugeot app as someone has mentioned above to see it helps but currently booked back in with dealership in a few days so see what they say then.

And having checked the paperwork - mine is a PureTech allure level no day nav.
 
21 - 28 of 28 Posts
Top