Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
452 Posts
Discussion Starter #1
Had this a few times now over last couple of weeks, I press key to unlock car and it does but wing mirrors do not move into position and car won't start.

Eventually it does start after wing mirrors have gone into position.

Fault indicators are orange SERVICE light is lit and green fog light on symbol is flashing.

If I mess with the lighting rotary switches the two fault indicators go off and all is well.

Any help please.
 

·
Registered
Joined
·
1,361 Posts
I would suspect the battery is weak OR has a loose connection.

On a CAN electrical system once the battery voltage gets low you will get all sorts of odd electrical faults & warning messages pop up.

First place I would check is the battery voltage & condition.
 

·
Registered
Joined
·
452 Posts
Discussion Starter #3
Will measure voltage before starting in the morning.

I know it is below the level required for ECO stop/start to work over two years ago.
 

·
Registered
Joined
·
452 Posts
Discussion Starter #4
Doors and wing mirrors ok, checked voltage briefly initially gave 12.5 volt then strange readings.
Started ok with no fault messages with engine idling 15 volt.

Looks like if I replace battery it will be £160 upwards, so do not want to spend needlessly, also frightened of rushing to be told it's finished just to sell me a new one. So if no further advice will see if the fault reports come back.
 

·
Registered
Joined
·
2,451 Posts
I bought an Endurolast battery from Rayna. Cost a lot less than £160. Full AGM spec. Prior to the change my battery volts were 15.3 and the LED numberplate lights kept failing. New battery and volts lower.
 
1 - 5 of 5 Posts
Top