Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, i could really do with some help as i have been having problems with my peugeot 207 GT, it is a 2008 model and it has done 45000 miles, i have had numerous problems with my engine witch i believe should be sorted now and a few weeks ago it had thrown out another fault code, witch brought my engine management light on and also had put my car into limp mode, the fault code was P3011 and the message was showing, ECU hrottle return spring ineffective any suggestions what this could be? Because also my engine sounds like it is still miss firing but no fault code has come up about that and the cooling fan always comes on when i start the car up, any help would be gratefully recieved.
 

·
Registered
Joined
·
8 Posts
limp mode

I have the same problem P3011 P3010 P2100.
I had an oil leak though the timing chain tensioner and the chain jumped 2 links had it re timed and the engine runs ok but can't do more than 30mph. I think it needs to be retimed or when the items were removed to get at the chain the throttle model wasn't put back correctly.
Please contact me if you solve the problem
 

·
Registered
Joined
·
1,337 Posts
Hi, i could really do with some help as i have been having problems with my peugeot 207 GT, it is a 2008 model and it has done 45000 miles, i have had numerous problems with my engine witch i believe should be sorted now and a few weeks ago it had thrown out another fault code, witch brought my engine management light on and also had put my car into limp mode, the fault code was P3011 and the message was showing, ECU hrottle return spring ineffective any suggestions what this could be? Because also my engine sounds like it is still miss firing but no fault code has come up about that and the cooling fan always comes on when i start the car up, any help would be gratefully recieved.
throttle body needs replaced, unfortunately is £198!!
 

·
Registered
Joined
·
1,337 Posts
I have the same problem P3011 P3010 P2100.
I had an oil leak though the timing chain tensioner and the chain jumped 2 links had it re timed and the engine runs ok but can't do more than 30mph. I think it needs to be retimed or when the items were removed to get at the chain the throttle model wasn't put back correctly.
Please contact me if you solve the problem
throttle body wouldn't been touched for when doing timing work, who did the timing? very lucky engine didn't go bang if had jumped 2 teeth on the chain!

good news is the fault codes u list are all related and are Motorised throttle motor control fault issue, so its basically a new throttle body you need to get,
 
1 - 5 of 5 Posts
Top