Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
Apologies for any second post on same fault.

Above fault code if anyone can shed light please.

Dealer put in new ecu but light back on.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
Gibbo I have another thread on same topic DPF fluid.

All info on there from start of fault, empty tank and refilled etc.

Lasts 48 hours then fault returns.

Thought id save you posting on 2 posts :lol:
 

·
Registered
Joined
·
57 Posts
Discussion Starter #4
Car still with main dealer, fault cleared at present, but has been cleared twice before only to return after 2 days.

Attached is the printout.

There is a can communication problem and suspect area is "Additive Pump"

Have said could be wiring issue, or possible BSI?? (your opinions again please)

If it's wiring, surely it wouldn't be fine for 2 days then reappear?

Car was serviced by my local garage just before the light came on, they are certain they did nothing to upset the system but have asked to be keep informed.

Can anything on a service cause this fault? The new filters etc.

They unplugged air mass sensor and fuel filter to replace the relevant filters, and opened the fuel cap to check seal.

I know I am going over old ground, but main dealer insist they have checked all possible opinions from advice I have been given on here, from fuse to fuel cap sensor fault and all are fine.

Short of replacing parts and wait and see, it is a case of them clutching at straws. Starting to think now they have no idea what to do and totally lost faith in it getting sorted.

Thanks to all who have offered their input, all I can do is relay it to the dealer.

Oh and if anyone knows of an able tech in Nottingham please let me know.
 

Attachments

·
Registered
Joined
·
57 Posts
Discussion Starter #5
so since mid april after a new additve ecu all has been good.
today light on again.
codes:
u0046
p1435
p2408
got them removed and now just top two on.

thought it was resolved weeks back!!!

back on saturday to peugeot but any advice appreciated.

aa told me what code mean what but wouldnt check further
 

·
Registered
Joined
·
57 Posts
Discussion Starter #6
lol i did, but another member suggested i carry it on from this one but i couldnt report it to merge as suggested.

that post is "depollution fault AGAIN"

please merge or amend as you see fit
 

·
Registered
Joined
·
57 Posts
Discussion Starter #7
It's the 1.6hdi 2006 model 307.

Dealer called asking strange questions.

Have I used abroad in a hot climate?

They think it is the BSI now, which could explain the 10 hours it took them to eventually reset the additive ECU a few weeks back
 
1 - 7 of 7 Posts
Top