Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi, just an update and questions about fault codes.

Stuck water pump led to timing belt fracture and consequently bent valve stems. Decided to undo top and repair.

Took quite a while to undo the valves due to lack of correct spring compression tool, also time to get the new valves from ebay supplier, and of course the grinding itself - when suffient.

However, put it all together with new valves and gaskets, and approximately 30+ connections to refit.

Checked timing by rotating crankshaft manually and also checking by optical scope clearance in cylinders at the same time.

Then started engine. Runs nicely. At first lots of smoke from oil residue, then steam from radiator that I cured with stop leak fluid. No water in engine oil, and no engine oil in cooling water.

Have driven 90 km since startup and no problems with torque, acceleration or speed up to approx. 110 km/h (not tested higher). Engine cooling water temperature at 90 degr. C and Oil temp. also about 90 degr. C. not much smoke from exhaust, just vapour and no indication of oil residues.

Why then fault codes:
At first:
P0342 Camshaft Position Sensor "A" Circuit Low
P0351 Ignition Coil A Primary/Secondary Circuit Malfunction
P0352 Ignition Coil B Primary/Secondary Circuit Malfunction
-> disconnected and reconnected camshaft pos.sensor plug
Now:
P0606 PCM / ECM Processor Fault
P0351 Ignition Coil A Primary/Secondary Circuit Malfunction
P0352 Ignition Coil B Primary/Secondary Circuit Malfunction

How to fix P0606 ?
Why P00351 and ..352 when engine appears to run smothly ?

Anybody got advice ?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
Hi, just want to give you a follow up on this car.

It now runs beautifully. Thing was, couldn't sort out the fault codes. However, a drive to the countryside, my cottage - solved the problem.

I got there. had been roadworks, entrence from road changed including too high side stones. I slowly reversed in through the gate, checking numerous times the clearance between the side stones and the underneath the car, especially the exhaust. At one point I decided the clearance was not enough, so put car in 1. gear to drive out of gate. In my clumsyness the car rolled back just a littlebit, just enough for the front edge og the rear exhaust muffler to get over the road stone edge. The car was stuck.

After numerous attempt to put something on the ground to run the rear wheels over to get clearance, I got so enoid that it failed, so I just tried drive out of the gate hoping not to make any significant damage to the exhaust and car.

Which was - I pulled off the complete exhaust system from the down pipe.

I put the bits in the car, put on ear mufflers, put on a few layers of warm clothes, opened the windows and set out for home - just 80 miles to go. I didn't get farther than 2 miles before the car went into limp home mode. By this short journey I was numbed by the dephening noise from free exhaust and dead cold.

So - next was to call rescue service, wait for 1 hr, freight the car to nearest garage, and train back home. 3 weeks later car was fixed, new exhaust, and no fault codes.

The engine repair - head off and fit new valves - still in good shape, car runs beautifully.

Lucky me, even managed to get some of the cost refunded from road project.
 
1 - 2 of 2 Posts
Top