Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have 2005, 407HDi and have following problem:

The Fan runs and I can hear it but the air is not coming through the vents. Is this a quick fix or I have to be slaughtered by the dealer. I showed it to a mechanic and he said this is elctronic control and he doesn't know too much about french electronics.

I did have a Particle Filter Problem and a mechanic filled it charging me about 110 where dealer was asking for close to 500 to fill it and reset the warning. I still need to know the exact location of the reservoir for the Particle Filter Fluid. If you can suggest the location and the colour of teh fluid then I think I should be able to figure out.
 
C

·
Guest
Joined
·
0 Posts
First, replace the pollen filter. It's an easy job, no tools required, and can make a big difference to the airflow. If your car is on it's original it'll be like an old lady giving you a blow-job through a piece of turf!

If that doesn't fix the ventilation, then you might have a problem - some of the gears that drive the flaps that open/close inside the dash are nylon, and it's not unknown for them to fail on older cars. If this is the case it's an expensive job as much of the dash has to come out.

Look under the car and you'll see an alloy shield that protects the ELOYS fluid. However, it is MASSIVELY corrosive and will very quickly burn through 2 pairs of rubber gloves, and many a DIY'er has ended up in hospital with burns through handling this stuff. I wouldn't recommend tinkering with it unless you're a skilled technician. In any case, you'll still need the dealers or someone with planet to reset the counters.

Good luck
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thank you chopper, I will try the Pollen Filter first. My Mechanic also mentioned it. I will see if I cna get it and then I will install it. Any suggestion where it is located?

On Elloy Fluid.
Something was leakin near the rear side passenger wheel and it had a Plastic reservoir with Red Liquid in it. Something like we add to teh Diesel or Petrol for Cleaning Injectors. I believe that is the Elloy Fluid but definitely it wasn't toxic as I changed the small tubing(which was leaking), This was also red in colour. Something regular person cannot do on the street as it requires to remove the resorvior and do it on the bench. Confirm if am I right in thinking that this is the resorvoir for the Particle Filter Fluid.

Thanks in Advance.
 
C

·
Guest
Joined
·
0 Posts
No worries, you're very welcome.

Yes, sounds like the ELOYS container. This link may be of use...

http://www.407owners.com/forums/viewtopic.php?f=18&t=1786

Under the glovebox is a piece of 'carpet' trim held on by 2 or 3 clips. Undo the clips (IIRC they just turn and release) and remove the trim.

Burried way back at the top/right corner you'll just see a black plastic cover. Ping this off and you can slide the olde filter out.

Refit is the reversal of removal, although it'll take some wiggling and bending of the new filter to get it in.

This wee linky may also be of use...

http://www.407owners.com/forums/viewtopic.php?f=18&t=175

Lemme know if you get stuck.

Good luck,

Chopper.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Perfect Links

No I did not get stuck. It was very easy to do when you make your mind to do it. The Links you have listed were great help. I found the Pollen filter, cleaned it and reinstalled it. And Vents works now. Tomorrow I will get the new filter and replace it.

My mechanic will be surprised how I fixed and why I dont take my car to him. Well he is cheap and does the good job on most mechanical stuff. So I will still give him some business.
 
C

·
Guest
Joined
·
0 Posts
That's excellent news!

We like nothing better than helping fellow pug enthusiasts save a few quid.
 
1 - 6 of 6 Posts
Top