Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all, having some problems with my wifes 306 2.0 hdi, since buying the cars 3 months ago the low coolant light has come on off as it wishes, also the fan does not kick in and in stop start traffic it over heats. I have changed the thermostat and still no change. The thermostat doesnt seem to open as i have remove sthe top hose when running at temp and no water is coming from the stat housing to the rad. Any suggestions would be greatly appreciated.
 

·
Registered
Joined
·
86 Posts
hi mary. do them cars have coolant sensors. if they do it can be faulty. i believe you can test a thermo by putting it in very hot water and it should open or close if it works, i'm sure which but i've read about it being tested that way
 

·
Registered
Joined
·
50 Posts
Hi I've had this issue on many cars . The thermostat is supposed to open at around 86°c give and take the boiling point for water when it under pressure boils at 120°c as this car got air con ? If so check the fan resistor next to the radiator If that broke fan will not come in. Check the relays and the wires going up to the relays the ecu controls when the fan will come in. If you get an half right scanner ie delphie ds150e clone you can activate the fan. if you click activate and it don't work check the above. You can pick the above scanner up for around £40 of eBay. It never let me down and it works on alot of other cars as well. Hope this helps. also with the above scanner you can watch the temperature live going up
 

·
Registered
Joined
·
50 Posts
Could the impellers have broke on the water pump ? have you checked the water for creamy deposits of oil. Have you checked your oil to see if it got any water in there. if you have the above. It could be your head gasket. You can also get a sniffer test done on the water to check for emissions in the water
 
1 - 5 of 5 Posts
Top