Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
had a aftermarket cat fitted in feb and had no bother until the other week
during a long trip engine management light came on and anti pollution fault was showing on dash display

took it to garage to get it checked (said it was showing a cat fault)and the reset the light but said it might come back which it did last week.

i bought a reader from ebay rather than paying £30 a time to get it reset and this code showed up P0420 cat system efficiency below threshold bank 1

reset the fault and light has stayed off so far.at no time when the light was on did the cars performance changed so what can it be causing this fault all of a sudden. dirty sensor? faulty sensor? faulty cat ? air leak in exhaust /cat system felt around the cat on start up and cant feel anything or is it a case of having non peugeot cat fitted that ecu will require reprogramming.

ive read elsewhere one cure can be to take the sensor out and replace it with blanking nut and secure the sensor in the engine bay away from the exhaust.dont want to be pulling money out as going to get shot later in the year hopefully could just be a case of keep reseting fault now and then see how long it stays off this time
 
D

·
Guest
Joined
·
0 Posts
Most likely a rubbish cat. The price of them usually tell the quality of them. So can I ask how much was it?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
£90 tried getting a second hand one but had nothing but bother even had one place send me one from a 207 saying it would fit as it was the same engine
 
1 - 3 of 3 Posts
Top