Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Evening!
For the last week, when I have started my car the engine management light has appeared. As soon as the car is running it turns off. Today when I started it, I had to reset the time and date and then when I turned the ignition the car wouldn't start. All interior lights remained on. The engine management light appeared and a message came up saying brake system management fault. When I tried to start the car again the message didn't appear but the car wouldn't start. Managed to get it started with jump leads. Also, when the car is sitting there, the revs are at about 7000 which isn't normal.

Im going to ring a garage tomorrow but was wondering if anybody could advise on what it might be. Please feel free to ask questions if this isn't clear enough!

thank you in advance!
 

·
Registered
Joined
·
4,777 Posts
Evening!
For the last week, when I have started my car the engine management light has appeared. As soon as the car is running it turns off. Today when I started it, I had to reset the time and date and then when I turned the ignition the car wouldn't start. All interior lights remained on. The engine management light appeared and a message came up saying brake system management fault. When I tried to start the car again the message didn't appear but the car wouldn't start. Managed to get it started with jump leads. Also, when the car is sitting there, the revs are at about 7000 which isn't normal.

Im going to ring a garage tomorrow but was wondering if anybody could advise on what it might be. Please feel free to ask questions if this isn't clear enough!

thank you in advance!
Check battery and alternator
 
1 - 4 of 4 Posts
Top