Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

My boyfriend recently bought Peugeot 307 sw, diesel 2ltr, 2004 and everything was perfectly fine. After 2 days it came problem, the engine light came on and also came a message anti pollution fault. Now he is saying that another message came - automatic wiping (wipers) active - I am not quite sure, because my boyfriend is not speaking English very well and he just told me over the phone. So... suppose to be something with the wipers... I tried to find solution online but nothing is coming for this wipers?! which means maybe its something else. Its hard to starts the car and its not driving well, the its loosing power all the time. I bought mini scanner to check the car for faults but I will do it today, its just arrived, so I can post the fault codes as well. I am not sure should I erase the fault codes or something can happen...?! As you can see I don't know much for cars, haha. I checked the car's history online and its coming this fault through the mot passing:
okay.. its not giving me to post links but I can send through pm
most of the fault are: E.M light on
service light on
play in steering rack inner joints
rear exhaust box deteriorated
problems with rear brake pads
rear exhaust section heavily corroded
rear wiper blade deteriorated
off side windscreen washer

Hope this helps. Also I search a lot for this problem and sometimes is a little thing as a some pipe or some bulbs... is it possible this one to become because of the bulbs? Also we are looking for good mechanic near Croydon area to check our vehicle.

Thank you, waiting for your reply.

Christina
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you trustme but will be helpful if somebody with same problem will help me or give me advice what to check if is a small problem. Also there is a problem if I can say its problem, just the ignition switch on the steering wheel its not working easy, you have to use it a little bit harder. Do you think is something with the code?

Also do you think that something will happen on the car if I erase the fault codes? :D

Thank you,

Christina
 

·
Registered
Joined
·
93 Posts
Sounds like you need new 02 sensors, If that don't work then i suggest a new catalytic converter.

pollution fault is what it says bad fumes.

That equals 02 sensor or catalytic converter.

02 are cheaper then a full cat why 02 suggested.

get them tested see if there the problem first.
 

·
Moderator
Joined
·
11,766 Posts
Thank you trustme but will be helpful if somebody with same problem will help me or give me advice what to check
The thing is that the same problem someone else had could be a different faulty part.

For example, when I've had the problem before, it was a faulty MAF sensor on one car and a faulty injector on another. Considering each part is around £100, plus labour if you can't fit it yourself you're risking throwing parts at what could be OK components.

Which is why we always recommend a diagnostic from one of us first as that can check the parts to see if they're faulty. A visual inspection won't show the fault.

Please read the FAQ again, as its clearly explained there.
 
1 - 5 of 5 Posts
Top