Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
When I put the key in the ignition turn prior to ignition the pre-heat sequence (it's diesel) goes great and all lights except the engine diagnostics light go out, the diagnostics light goes out within 3 seconds of the engine starting though. Also recently the car displayed 'economy mode activated' if that is related. What is likely to be the cause?
 

·
Registered
Joined
·
862 Posts
tomgaa said:
When I put the key in the ignition turn prior to ignition the pre-heat sequence (it's diesel) goes great and all lights except the engine diagnostics light go out, the diagnostics light goes out within 3 seconds of the engine starting though. Also recently the car displayed 'economy mode activated' if that is related. What is likely to be the cause?

Check all the fluid levels pretty sure the engine is needing something topped up,that will solve both lights.
 

·
Registered
Joined
·
1 Posts
tomgaa said:
When I put the key in the ignition turn prior to ignition the pre-heat sequence (it's diesel) goes great and all lights except the engine diagnostics light go out, the diagnostics light goes out within 3 seconds of the engine starting though. Also recently the car displayed 'economy mode activated' if that is related. What is likely to be the cause?
Hello,
the engine diagnostic light is the ECU doing a system check and will stay on for about 3 seconds then go out. If it stays on thats when you have a fault. The " economy mode activated " message is the car saving battery life. It comes on when you have the ignition on for about 30 mins without the engine running and it cuts power to certain equipement to stop the battery from going flat. If you restart the engine it reactivates them again.
Hope this is of some use to you.
 
1 - 3 of 3 Posts
Top