Peugeot Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
My 57 plate 1.6 VTi is back at the dealers for a 3rd time with engine cut out problem. First happened in '08, garage wouldn't accept anything wrong until I handed them a thread from this site saying that there was! downloaded a fix from Peugeot and all was fine.

2 months ago stupid Anti Pollution light came on - they replaced the exhaust sensor, since doing that there was a distinct loss of power and car was bunny hopping down the road.

Over the weekend engine cut out twice while at junction and wouldn't start the next day - engine fired up 5 times but each time cut itself out.

I've got a funny feeling that garage are going to tell me that nothing's wrong and that i've been stalling the engine and the computer can't find a problem.

Anybody else experienced this and have any solutions?
 

·
Registered
Joined
·
134 Posts
fault

hi,,the first thing to look at on these engines is the cam chain timing!
huge problem.
also i would ask them to reset autoadaptives,as this causes problems also,particularly after a download.
when you speak to them ask what codes have been retrieved.
if they say none,,ask for the bsi faults journal codes then(impossible to have none in that,wether relevant or not)

toddy
 

·
Registered
Joined
·
3 Posts
fasham01 said:
My 57 plate 1.6 VTi is back at the dealers for a 3rd time with engine cut out problem. First happened in '08, garage wouldn't accept anything wrong until I handed them a thread from this site saying that there was! downloaded a fix from Peugeot and all was fine.

2 months ago stupid Anti Pollution light came on - they replaced the exhaust sensor, since doing that there was a distinct loss of power and car was bunny hopping down the road.

Over the weekend engine cut out twice while at junction and wouldn't start the next day - engine fired up 5 times but each time cut itself out.

I've got a funny feeling that garage are going to tell me that nothing's wrong and that i've been stalling the engine and the computer can't find a problem.

Anybody else experienced this and have any solutions?

I am experiencing similar problems. 207 gt 56 reg. Ive just had the knock sensor replaced. it made the difference but its now back to how it was before. Ive just been to my garage and hes saying that it could well be the Timing chain. Think he called it that. My engine has a knock on it when its running. Also when the car is turned off the fan comes on. The other problems is like you described, hopping down the road with a noticible loss of power. Its as though theres not enough fuel going through the engine. my mechanic has checked the injector and thats ok. This car has been trouble 2 out of the 3 years ive had it. I cant wait to get rid.
 

·
Registered
Joined
·
4,511 Posts
i had a very similar problem a year ago now, got my timing belt changed (albeit) at a dodgy plaice.
going down motorways i get a beep - anti pollution fault followed by catalic converter fault then slowing in limp mode.took forever to get to 10 mph... long story cut short it turned out the pully was at fault as it was on too tight/loose (cant remember) but it cost £200 to get fixed but got my money back from garage who did it in first place.

hope this helps fella's
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
An update...

Gargage are replacing another sensor tomorrow...will it work or won't it? keep watching!!
 

·
Registered
Joined
·
134 Posts
not

hi i'll stick my neck out now and say not!!!!!!!!
toddy
i hope for you it does tho..:)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Peugeot Garage..

Good news, the engine is going again! fingers crossed it will keep going.

Advice from the mechanic was that because it is a BMW performance engine (??) I should thrash it every now and again...we'll see!
 
G

·
A performance BMW engine designed by Peugeot and derived from the older PSA XU alloy block (they still share the same bore/stroke), but otherwise a BMW!
 

·
Registered
Joined
·
3 Posts
i recently had my tracking chain replaced and its seems to have worked. theres no more kangarooing down the road. It cost another £350 fitted. whats my chances of getting some money back out of peugeot for all the hassle ive had with my gt.

Its only done 27400 miles and had lots of problems with this car. 2 fuel pumps, door locking mechanism broke, loss of power 3 times (back to the garge), depollution warning symbol alerting me 3 times(back to the garge).window not going up on the passenger side(back to the garge). knock sensor replaced. Tracking chain replaced. Im going to write peugeot a letter and see where it gets me.
 

·
Registered
Joined
·
14 Posts
Another 207 owner facing the unreliability issues and the DEPOLUTION SYSTEM FAULT.

When will Peugeot sort this out?

My issues,

numerous problems with electric windows
brake sensor
Timing all replaced
engine out to replace ignition components
Lambda sensor
Stereo eats cd
Windscreen wipers stop working
Clutch master and slave cylinder

Depolution system fault again
and again
and again

etc you get the picture:mad: :(
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top