Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
407 2.2 petrol 05 plate. the engine light has been for over a year now and have been told its a map sensor fault, it has been changed numerous times and still comes on after a couple of days of being replaced, abs/esp light constantly on , and every time I brake I get faulty light warning for rear right cluster but all the bulbs are fine . starting to lose the plot , any advice much appreciated.
 

·
Moderator
Joined
·
2,757 Posts
Hi.....just about the bulbs...although they are fine ...are they illuminating?...my 407 and other models have a regular fault where the earth or feed is lost at the multi plug on the rear light unit causing light faults to show up...mine was on the indicator making it flash fast....easily cured by bypassing the plug with a jump wire direct to the unit.....perhaps yours is on the brake bulb feed?
 

·
Moderator
Joined
·
2,757 Posts
I 'looked' at mine and didnt see anything wrong...so I ran another wire to bypass the earth pin and all is well after 4 years...the fault is in the light unit socket ... very hard to see..There is somewhere on this forum a guide on how to do it or poss youtube....
 

·
Registered
Joined
·
1,024 Posts
(1) Engine management: get it plugged into PP2k
https://www.peugeotforums.com/forums/maintenance-9/diagnostic-peugeot-planet-map-7734/

(2) Bulb warning on braking: known fault with bad earth in rear light cluster.

(3) ABS/ESP. 407s eat ABS sensors. PP2k will tell you which one is out.
The rear ones can be drilled out as the hole goes straight through: the side of the sensor sits against the magnets. However you have to be more careful with the front because it's the end of the sensor that sits against the magnets. In both cases the magnets are in the wheel bearing.
 
1 - 7 of 7 Posts
Top