Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi all . I’m new to the forum and have only been driving a year and a half . Last year I bought my first car a 57 plate 207 1.4 petrol . I had a nightmare getting it MOT’d earlier in the year due to high emissions I had the thermostat housing replaced and then the lambda sensor . Today I’ve had a anti pollution warning fault appear ���� . I’ve had a google and read lots of horror stories! Has anyone had any experience of this , Can anyone help ???
Thanks ��
 

·
Registered
Joined
·
37 Posts
Get the code's from the ecu read, it could be something as simple, but get the codes and we can help, maybe someone is near you with diagbox pp2000
 

·
Registered
Joined
·
120 Posts
Have a look at the coolant. Any oil or dirtiness about it? I have same fault. In my case its a blown head gasket. Check the oil cap also.

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thank you both so much ! The oil cap was “creamy “ when I bought it back in August but cleaned it out and hasn’t come back . I have had to top up the oil a few times but the water and the coolant are full and clear .
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thank you for the tip about the diag box and pugeot planet . I’ve messaged a local member
 

·
Registered
Joined
·
120 Posts
The only other thing to do while your waiting for a code readout is to disconnect the vaccum pipe, above the coils, unbolt and pull off the coilpack (might need help of a large spanner as a lever but be careful not to break anything) and get at the sparkplugs, (size 14mm deep socket needed), and look at their condition and colour.

There are online colour guides to see if the cylinder is burning oil or has other valve problems just be looking at the sparkplug colour, or maybe the sparkplugs are worn out and are actually causing the fault.

Get someone to rev the engine a little and examine the exhaust gas. Is it white or brown or normal?

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Thank you all so much !!!! Diagnostics looks like it’s the rear lambda sensor (phew)
 
1 - 8 of 8 Posts
Top