Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hello everyone.

I recently bought a 308 1.6 vti form 2009.
On the driver door i have a button for child lock.
When you press it , the led should stay on , and the rear doors and windows should be locked. Also on the display should say that the child lock safety is activated. At my car when i press that button , the led lights for 1 second and then it turns off. The rear doors are locking so i can`t open them from inside , but the windows are still functional. On the display nothing appears. Also if i press again on that button it should deactivate the option , but when i press it nothing happens. After about 1 minute the rear doors will unlock so you can open them from inside again.
I have PP2000 and i took a look in the system. No errors on the central locking everything looks good.
The Central locking is set as - Deadlock
The Electric Child safety is - Activated
Acquisition of the child lock request - by the door electronics.
In PP2000 is a info for the last option where it says.
Must be set to : By the door electronics if the vehicle is fitted with one-touch rear electric windows or By the built-in system interface for the other variants.
My rear doors has the 2 positions electric window button. When i full press the button and release, the windows goes down at maximum.
So i assume the doors are fitted with one-touch rear electric windows and the setting is correct.

Anyone any idea ?

Thank you very much !
 

·
Registered
Joined
·
22 Posts
Discussion Starter #2
So ... i found something strange.
When i open the rear left door , the lights inside the car will not come on , and on the dash the computer does not alert me that the rear left door is open.
So the computer thinks the door is closed.
Today i checked the wiring loom at that door ( From mid-frame to the door ) and there is no broken wire.
I understand that if the wire is shorted to ground the computer will see the door closed ( as a safety feature to be able to lock the car )
As i don`t have any broken wire between the door and the mid-frame i was thinking that the open / close switch is faulty , and has blocked on the lock position. I heard that the switch is in the lock. Did anyone had this problem and solved it without replacing the lock ?
At first i was thinking ... ohh this is why my electric child lock does not work , because of that door. But then i was thinking again , and it should work , because the computer see the door closed , not open. Unless a cable is broken somewhere else ( maybe inside the door frame ).
On the Diagbox / PP2000 i have no error regarding the door modules / locking system etc...
Any idea ?

Thank`s !
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Maybe this weekend i will have time to check the cables from the lock to the mid-frame connection. So if one is split is easy , but if all cable has continuity it will be the lock.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Solved

Hello everyone.

The problem has been solved.

I just removed the door card and now everything is working as it should.
Maybe a loose contact or something with the rear electric window command.

Have a nice weekend everyone !
 

·
Registered
Joined
·
2 Posts
Hello everyone.

The problem has been solved.

I just removed the door card and now everything is working as it should.
Maybe a loose contact or something with the rear electric window command.

Have a nice weekend everyone !
Hello there. My car is Peugeot 3008 and I'm having the same problem. exactly which piece you call the door card? Can you add relevant images?
 
1 - 6 of 6 Posts
Top