Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I installed a new Stereo in my 2007 207 1.6 today and everything seem's to be working well aside from the steering wheel stalk controls however the car has now started going into Eco mode when not running and wasn't doing this before.
Is this something I should be worried about, is the new Stereo draining the battery?
The car is starting okay but the Eco mode thing is worrying.
 

·
Registered
Joined
·
15,377 Posts
Its not the radio thats making it go into eco mode its the extra current drain of the new radio eco mode is used to stop the battery draining to much.

If the radio still works when eco mod comes on it is not wired correctly i will go further and say its most likely not wired correctly anyway

Eco mode turns off all non essential loads including the radio.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
No, the radio goes off when it goes to ECO Mode. It's just that it never did it with the original radio.
Worried that there might be a wiring issue alright.
Just wanted to check on here if it might be normal when a new radio is fitted if ECO Mode starts working.
 

·
Registered
Joined
·
15,377 Posts
It would have did it with the original radio it would just have taken longer as it drew less current im assuming you have fitted a more powerful radio so it will draw more current as you have it louder etc

If you have also installed an amp this will draw more current too

It could just be your battery is tired and the extra load is too much for it
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Yeah, the new radio is stronger. I can live with it, was just worried it might be causing a major fault.
Thanks for the insight.
 
1 - 5 of 5 Posts
Top