Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Having a problem with the lock on the car. The remote works and will unlock all doors apart from the drivers door. The key turned in the lock unlocks the door and operates the central locking fine. the remote will also lock ALL doors.
I have tried a BSI reset with no change, does anyone else have any ideas?
 

·
Registered
Joined
·
4,777 Posts
Having a problem with the lock on the car. The remote works and will unlock all doors apart from the drivers door. The key turned in the lock unlocks the door and operates the central locking fine. the remote will also lock ALL doors.
I have tried a BSI reset with no change, does anyone else have any ideas?
sounds like drivers door actuator needs replacing (the lock mech in the door)
 

·
Registered
Joined
·
2 Posts
door lock

It Could be this,

I had the same problem with my wife's 307cc , take door card of and you will probably find that the bar that actuates the lock has fallen off from the lock, simple fix ,just push bar back into nylon clip , :thumb:
 

·
Moderator
Joined
·
5,630 Posts
Also check door harness where it links from the door to body, the flexing when doors open/closed can break wires
 

·
Registered
Joined
·
66 Posts
Discussion Starter #6
Had a look tonight, took door card off and checked the connections. I pushes the connector and fiddled with the wires. Nothing really moved and couldn't see anything wrong. Put the card back on and it works very few times. So looks like either a loose/faulty wire or connector!
 

·
Registered
Joined
·
4,777 Posts
Had a look tonight, took door card off and checked the connections. I pushes the connector and fiddled with the wires. Nothing really moved and couldn't see anything wrong. Put the card back on and it works very few times. So looks like either a loose/faulty wire or connector!
try spray some wd40 in the mech
 

·
Registered
Joined
·
66 Posts
Discussion Starter #8
Taken card off again and sprayed wd45 on the link rods and lock. Still not working all the time. Can't see and damaged wires so looks like faulty module. I can still open the car with the key which does activate the central locking so will put up with it for now and look at getting a new mod
 
1 - 8 of 8 Posts
Top