Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi Guys...

Recently got the car back from the repair shop, and ever since I have been getting a tone and message saying Direction Indicators faulty, either when braking or indicating left... Occasionally getting Rear Stop light faulty as well..

Could this be from the garage removing and replacing the rear light clusters?

Or is there a more common diagnosis for this?

Thanks Guys....

Pete
 
C

·
Guest
Joined
·
0 Posts
Yes, almost certainly.

Older models had a poor earth in the rear clusters and this confused the BSI making it think bulbs had failed all over the shop. First, double check all the connectors are pushed firmly in place, and if that doesn't do it then search this 407 forum for the rear lamp eart modification, which is simple and very effective...a bit like me!
 

·
Registered
Joined
·
14 Posts
Rear cluster bulb / stop light faulty message

The indicator and stop light faulty message was appearing after a day or so of driving my 407. I have read a few threads in this forum advising what to do about this problem so I took out both rear clusters, gave the connector blocks a good spray with WD40, sprayed the earth fixing points on both sides and reseated the clusters. So far, the messages have stopped coming up. It may not work for you but it is worth a try?
 

·
Moderator
Joined
·
5,087 Posts
mine does this every now and then,but its not the usual corrosion causing it,on mine its the n/s rear light that causes the problem i just unplug the light,blow into the plug then plug it back in,works for about 6 months then i do it again:thumb:
 
1 - 4 of 4 Posts
Top