Peugeot Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
I have had nothing but problems with the additive system on my 307 2ltr hdi 110.
Step taken so far to rectify faults are :-
1 Fitted new fuel cap sensor as old 1 was not working.
2 Refilled dpx42 tank with 4 ltrs of new fluid, after doing this and clearing all fault codes and reseting the fluid counters to zero the planet reader was still showing the tank as empty.
I had a peugeot master tech to check my car and he seemed to think my dpx tank was faulty and that the fluid level float inside was stuck or had failed.
He said sometimes you can free it with a tap or 3 from a rubber mallett or hammer shaft, i tried this to no effect and ordered a replacement tank.
The tank is now fitted and refilled, reset levels in planet to zero again, now it shows "Minimun level not reached" instead of Minimun level reached, Wait" so new tank seems to be good.
Also ran the pump actuation thing in planet 5 times to prime the pipes/pump.
Now i need to know how i get it to start doseing the diesel tank with the additive, it still says " amount of additive injected = 0.
I have not added any fuel yet but have removed the fuel cap for about 15 seconds, do i need to simple add fuel for it to start doseing?
Thanks in advance for any help. ;)
 

·
Registered
Joined
·
905 Posts
theblob said:
I have had nothing but problems with the additive system on my 307 2ltr hdi 110.
Step taken so far to rectify faults are :-
1 Fitted new fuel cap sensor as old 1 was not working.
2 Refilled dpx42 tank with 4 ltrs of new fluid, after doing this and clearing all fault codes and reseting the fluid counters to zero the planet reader was still showing the tank as empty.
I had a peugeot master tech to check my car and he seemed to think my dpx tank was faulty and that the fluid level float inside was stuck or had failed.
He said sometimes you can free it with a tap or 3 from a rubber mallett or hammer shaft, i tried this to no effect and ordered a replacement tank.
The tank is now fitted and refilled, reset levels in planet to zero again, now it shows "Minimun level not reached" instead of Minimun level reached, Wait" so new tank seems to be good.
Also ran the pump actuation thing in planet 5 times to prime the pipes/pump.
Now i need to know how i get it to start doseing the diesel tank with the additive, it still says " amount of additive injected = 0.
I have not added any fuel yet but have removed the fuel cap for about 15 seconds, do i need to simple add fuel for it to start doseing?
Thanks in advance for any help. ;)
the mastertech should have told you that once you have carried out the work, you need to fill in 10 litres and do the fuel cap maneuvour to teach the ECU, that the work has been carried out...
 

·
Registered
Joined
·
91 Posts
Discussion Starter #3
Scotcruz said:
the mastertech should have told you that once you have carried out the work, you need to fill in 10 litres and do the fuel cap maneuvour to teach the ECU, that the work has been carried out...
Thanks m8 i'll give it a fill today, what do you mean by cap maneuvour?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #5 (Edited)
Ok poped in £15 of fuel which works out to about 13ltrs i think had a little drive, got home plugged in planet and low and behold i have minimum level reached errors, crawled under car to check tank and its full.
So i disconected the battery following the 3 min rule, reconnected following the reconnect procedure, plugged in planet again and all faults have cleared.
Now do i have to go put more fuel in again? And was i wrong in putting more than 10 LTRS in?
Arrrh im gona smash this car with a big hammer soon:mad:
 

·
Registered
Joined
·
103 Posts
it did take me about 2 days mate for it togo. If u can just forgot about it for a bit and keep driving it should reset its self. U did say u replaced the cap to?

But i could be wrong mate but its just wot happend to me.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #7
Yeah replaced cap sensor aswell, i should have checked before i went to refuel that i had no faults, but it never entered my mind as there were none after i completed the work yesterday.
 

·
Registered
Joined
·
905 Posts
theblob said:
Yeah replaced cap sensor aswell, i should have checked before i went to refuel that i had no faults, but it never entered my mind as there were none after i completed the work yesterday.
you will be fine mate.. it will go.. as long as you manuevour the cap..

way its done is open the cap leave it open and take the cap off for 2 minutes..

put the cap back on and shut the lid..

wait 5 minutes, dont touch the car.. let ECU/BSI sleep

this is the standard maneuevour after refilling aditive
 

·
Registered
Joined
·
91 Posts
Discussion Starter #10
Ok tried it twice and all i get is the return of "minimum level reached wait" in the engine section of planet duno if thats correct but i don't think it is.
 

·
Registered
Joined
·
905 Posts
theblob said:
Ok tried it twice and all i get is the return of "minimum level reached wait" in the engine section of planet duno if thats correct but i don't think it is.
post your PEF Parameter screen from Planet so we have a look... its strange..
 

·
Registered
Joined
·
91 Posts
Discussion Starter #12 (Edited)
Sorry its taken me so long to reply i have done a series of screenshots in planet for you.
In the zip file is 3 folders numbered and named in the sequence of what i have been doing.
I have had to upload to a fileshare website as the file is larger than we are allowed to attach here.
I think it should be clear enough but if not let me know, and thanks so much for trying to help m8 i really want to get this sorted.

Heres the file download :- http://www.mediafire.com/?i33513i55mow336

Thanks again.:thumb:
 

·
Registered
Joined
·
905 Posts
theblob said:
Sorry its taken me so long to reply i have done a series of screenshots in planet for you.
In the zip file is 3 folders numbered and named in the sequence of what i have been doing.
I have had to upload to a fileshare website as the file is larger than we are allowed to attach here.
I think it should be clear enough but if not let me know, and thanks so much for trying to help m8 i really want to get this sorted.

Heres the file download :- http://www.mediafire.com/?i33513i55mow336

Thanks again.:thumb:
Hi mate,

Your car is not dosing Eolys into the tank which could be an electric issue.

looked at your pics, and my thoughts are:

  • Fuel Cap Sensor Faulty (this gives a signal to Additive ECU which injects Eolys in the tank) strange as you say that it has been replaced
  • Additive ECU not initialised properly
  • Short or open circuit between Fuel Cap Sensor and Additive ECU (may need to replace the additive tank)
I will see if I can find any diagrams for it... did you replace the Fuel Cap Sensor yourself?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #15 (Edited)
Yes m8 i replaced both the cap sensor and additive tank myself.
I feel the sensor is ok as if i have the parameters screen active for the additive ecu with the cap in place it says fuel cap present, if i then take it out it shows as absent or not present i can't recall of the top of my head the exact words.
As soon as i pop the cap back in it registers as present again.
Oh i forgot to mention when i originally spoke with the pug master tech he mentioned something along the lines of if replacing the additive tank does not sort it it could be the ecu needs to complete a power latch, i have no idea what that means other than maybe dissconnecting the car battery for a set time?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #16
Today i decided to dissconnect my battery for 3 hours just to experiment.
It has not made any difference at all.
I still get minimum level not reached when battery is first reconnected then as soon as i do anything with the fuel cap trying to get the ecu to learn the fluid levels the dreaded minimum level reached wait fault pops it ugly head back up in the engine ecu.
Im thinking either i need a new additive ecu or even engine ecu, or maybe my ecu needs an update, i duno im lost.
 
1 - 16 of 16 Posts
Top