Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all I’m new here so any help would be greatly appreciated.
What my problem is; firstly the engine light came on along with the dash warning “anti-pollution faulty” Took it into Peugeot and the charged me to read the codes and told me the EGR valve was faulty and tried to charge me £800.
Fitted a new EGR valve myself, £145 but then they charged me £95 too have a download put to my ECU to tell the car a new valve had been fitted.
Very next morning, the “anti-pollution faulty” warning returned, Peugeot, couldn’t explain and kind of gave up!
So I drove the car for two months, apart from an occasional lack of power (lip mode or no turbo?) I carried on without any problems.
Then the car gave up and wouldn’t get me home, starts and runs OK, but the minute I try to accelerate, the car just dies.
As I got towed home, (5:30 in the morning ARRRRG :mad:) and I can’t get the car back to the garage to read the codes again, and keep paying £50 to £100 to get codes read and deleted, I bought the wires Lexia 3 etc., from Jim at Easy diagnostics. (found him on here)
Loaded everything up and read the codes below, I think I may have problems with the dreaded DPF, but I’m not sure, and don’t want to strip/clean etcetera if that’s not the cause.
Can anyone take a look at my fault codes below and advise? I think the ECU and power steering are a bit of a red herring and the problem is with the Injection/Ignition section, any ideas?
Again thanks in advance for any assistance



Built-in Systems Interface
F000 Engine fuse box fault ECU not communicating on the CAN

Injection/Ignition
P1490 Regeneration not completed
P1351 Preheating relay circuit
P2033 Catalytic converter downstream temperature signal
P0299 Turbo pressure electrovalve control
P0299 Turbo pressure electrovalve control (yes it does appear twice)
P0192 Diesel pressure signal

Power steering electric pump unit
C1210 Fault engine running

Engine relay unit
F000 Engine fuse box not communication on the CAN fault
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
sorry guys, I forgot to add it's an 07reg 1.6 HDI, if anyone has any ideas of where to start, it would really help as I'm going to try to get it fixed over the weekend
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks guy's I read so much about DPF playing up I assumed that would be the cause.

Thanks again, gives me a good starting point
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Hi all,

A quick update and further help if possible.
Changed Glow plugs as recommended, changed the Turbo Electro control Valve, and replaced the glow plug relay, and changed the downstream temperature sensor and cleared the codes. Tried to run a forced regeneration, the car ticks over for 60 sec’s as it should, the rev’s build up to 4,000rpm as they should and after about 7 mins it all comes down, but the Diagbox says regen complete but Not OK.

So still no fault codes so I drive the car to work, 45mins on dual carriageway then round town, absolutely no problems no engine lights, faults, nothing, great.
Came out of work last night the car runs 20 yards and stops! It will start and tick over, but the minute you press the accelerator it stalls.

Plugged in the Diagbox, and get the codes

P2033 Catalytic converter downstream temperature signal (Short circuit to positive or open circuit or valve too high)

P01902 Diesel pressure signal (Short circuit to earth or value too low)

Clear the codes, try to pull away same thing car stalls.
Please help, I don’t know where to look next
 

·
Registered
Joined
·
9,733 Posts
I would check the filter in fuel tank sounds like dirt being sucked up tight to gauze when you ask for more ,with pp2000 you can check fuel parameters , you can also check dpf % load


Sent from my iPhone using AG Free
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Hi Bettyswoolocks,

thanks for the reply, great help thankyou
can I get to those parameters via diagbox, as I've got the win7 version from easydiagnostics and the PP2000 does'nt seem to work, probably because I'm running on win7 not XP? but Diagbox works fine
 

·
Registered
Joined
·
369 Posts
I would check the filter in fuel tank sounds like dirt being sucked up tight to gauze when you ask for more ,with pp2000 you can check fuel parameters , you can also check dpf % load


Sent from my iPhone using AG Free
Do you know what the pdf % load should normally be before, after regen and over due?
Have never seen a reference point.
 
1 - 10 of 10 Posts
Top