Peugeot Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,

I've had a 306 HDi for a few years now and have used the forum more than once to help with an issue, so thought that I would actually join now and try to repay some of the help I've found here.

As an introduction, I thought I might describe some of the trials and tribulations I had getting Diagbox/PP2000 to work over the last week (yes, it took that long!) so hopefully others searching for solutions might benefit.

I got a clone Lexia revision C with bundled Diagbox software from eBay for about £50. Didn't want to dual boot the laptop, so installed according to instructions (or so I thought) in a Virtual XP machine, using VirtualBox.

My first problem was that everything worked fine until I chose my car in Diagbox and got to the screen saying 'Selection of the application' which gave the options of 'Diag Tool' and 'PP2000'. Whichever option I chose, I simply ended up back on the same screen. Some searching in the forums revealed that I needed 32-bit XP, and I had installed 64-bit. Whilst Diagbox itself will run in 64-bit, the PP2000 element is a 32-bit only sub-program. Made a new Windows XP 32-bit virtual machine, and problem solved.

The next problem was that, whilst I could now get into pp2000, I could not get communication with my ECU - It just kept saying 'The ECU did not reply'. There turned out to be three elements to the fix for this one:

1 - The DAM number I was entering was incorrect. It seems that if your build number begins with a '0', you should leave that off, and input the next four digits - otherwise, it's just the first five digits. This might not be completely correct, but missing the '0' off seems to work in my case anyway, and other seem to have found the same thing

2 - I was not aware that I had to choose the '306R' option, not the '306' option, as the 'R' refers to phase 2 & 3, whereas the simple '306' option is only for phase 1.

3 - Whilst I was signed in as an administrator in the XP virtual machine, this was meaningless, because I was not signed in as an administrator on my Windows 10 host. Now I run the virtual machine from an administrator account within Windows 10, all problems seem to be cured!

Anyway, I hope this helps someone. Hopefully I shall be getting myself added to the PP2000 map, so hopefully see some of you soon!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top