Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,860 Posts
Discussion Starter #1
Ok folks please be a little gentle having bought installed diagbox on a xp laptop comes the long learning curve.

On a generic reader I have had mainly p0489 egr fault
And pending p0409 egr circuit fault

I had a fair few problems in not being able to verify user without Internet so no idea if I should be on line or not.

So diagbox is saying doser operation, my thoughts

Doser body where it fits on the engine is damaged I have bought sealer but due to heavy rain not yet tried. I have a k&n air filter may that be an issue.

Any ideas thoughts would be appreciated

Thank you

Allan


Sent from AutoGuide.com App
 

·
Registered
Joined
·
1,860 Posts
Discussion Starter #3
Thank you Gibbo

I managed among the rain to repair the holes in the doser under body and noticed oil from the pipe had contaminated a multi plug I cleaned all plugs and sockets with contact cleaner used sealer on the pipe that let oil pass and used a glove finger tp seal the plug.

Also cleaned sensor plug on maf just in case.

Will stick with k&n for now until I need to remove the slam panel again

The light was on this morning drove 3 miles took dogs walk came back light was off stopped for fuel 42 now 47 mpg started light back on Grrr lol

Not sure what to try next the car drives well and is much improved from buying it I thought it was fit when I drove it but now after a rover 25 feels like I have a rocket motor.

Would just like to extinguish the pollution light and as its not egr related don't see dpf removal would sort it out.

Thanks





Sent from AutoGuide.com App
 

·
Registered
Joined
·
1,860 Posts
Discussion Starter #4
Hi

Well had diagbox on again looks as if i have a permanent fault on BSI so that is one of my next jobs trying to work out if my dpf is gone already as ecu can not read additive
 
1 - 5 of 5 Posts
Top