Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
Hi all, my car is 407 2.0 HDi sport on 56 plate.

A few months back I accelerated hard from cold start and got the depolution fault come up. It came on for next couple of starts and then disappeared on it's own so I guessed it was just down to how I was driving at the time.

The other day I was driving on the motorway at about 90 to 100 MPH and I was low on fuel. The light came on and depolution system faulty came up again. Only thing is, it has stayed on this time and on every time I turn engine on. There is no chnage to the running of the car and everything seems smooth.

Is there anything I can try to solve the problem? I am sure it is maybe just crap in a filter from bottom of my tank or something (as I was low on fuel) but I dont know where these filters are or if they are easy to access and replace/ clean. Can anybody give me any clues as I have no manual? I am not a stranger to DIY mechanics as long as it is not too complicated or special tools required but then again I only used to tinker with older cars. But I cannot afford to go to Peugeot at the mo and it is frustrating me. Any advice on this would be great. Is a change of fuel or redex likely to be of any help?

Also, once the problem is solved will the light and fault automatically go out or does it require a reset? And does it need to be peugeot to reset or can I do it? I know it went out the first time round with no reset required but if it's anything like my last car (Renualt), once you start the car with the fault so many times the fault code remained until reset by a computer. Is this the same with peugeot?? Part of me wonders if there is no problem and it might just need a reset???

thanks for any help you can offer :)
 

·
Registered
Joined
·
9,733 Posts
timanfiya said:
Hi all, my car is 407 2.0 HDi sport on 56 plate.

A few months back I accelerated hard from cold start and got the depolution fault come up. It came on for next couple of starts and then disappeared on it's own so I guessed it was just down to how I was driving at the time.

The other day I was driving on the motorway at about 90 to 100 MPH and I was low on fuel. The light came on and depolution system faulty came up again. Only thing is, it has stayed on this time and on every time I turn engine on. There is no chnage to the running of the car and everything seems smooth.

Is there anything I can try to solve the problem? I am sure it is maybe just crap in a filter from bottom of my tank or something (as I was low on fuel) but I dont know where these filters are or if they are easy to access and replace/ clean. Can anybody give me any clues as I have no manual? I am not a stranger to DIY mechanics as long as it is not too complicated or special tools required but then again I only used to tinker with older cars. But I cannot afford to go to Peugeot at the mo and it is frustrating me. Any advice on this would be great. Is a change of fuel or redex likely to be of any help?

Also, once the problem is solved will the light and fault automatically go out or does it require a reset? And does it need to be peugeot to reset or can I do it? I know it went out the first time round with no reset required but if it's anything like my last car (Renualt), once you start the car with the fault so many times the fault code remained until reset by a computer. Is this the same with peugeot?? Part of me wonders if there is no problem and it might just need a reset???

thanks for any help you can offer :)
Click on the Peugeot Map below and see who is nearest to you with Diagnostics because first thing you need is code readings and these guys will do it cheap.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
bettyswollocks said:
Click on the Peugeot Map below and see who is nearest to you with Diagnostics because first thing you need is code readings and these guys will do it cheap.
I didn't realise that you had a list of Planet owners at first, having trouble finding them on the search though. I'm in Manchester.

Do you know if the fault automatically goes out when it's fixed or would I need to get someone with Planet to reset too?

Also, any idea how much i'm looking at to get a diagnostic code off one of these guys?
 

·
Registered
Joined
·
9,733 Posts
timanfiya said:
I didn't realise that you had a list of Planet owners at first, having trouble finding them on the search though. I'm in Manchester.

Do you know if the fault automatically goes out when it's fixed or would I need to get someone with Planet to reset too?

Also, any idea how much i'm looking at to get a diagnostic code off one of these guys?
Start a thread looking for "Vpug" , charge wise i do it for £20
 
C

·
Guest
Joined
·
0 Posts
Sounds similar to problem I had on mine turned out to be the egr valve.

If thats what it turns out to be get in touch may be able to help I've just changed mine.

Cris.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #7
Thanks Cris, I will let you know. What is the EGR valve?

I'm initially just trying some redex and exellium diesel rather than regular from supermarket. Not sure if that will help but can't hurt. What i don't know is if that does clear up the problem, will the warning just go out or does it need resetting??
 
C

·
Guest
Joined
·
0 Posts
EGR exhaust gas recirculation valve.

photo attached to show what it looks like it's between rear of engine and bulkhead on passenger side, remove engine cover and follow silver pipe to the back of the engine and pipe is attached to the egr.
Dealer quoted £240 for valve alone. I found one on ebay new and original part for £110 and fitted it myself.
As for the engine man light to be honest I aren't sure, my light wasn't on initially when I found the fault with planet but I cleared the fault and after driving for a minute or two I got light on and depollution system faulty but car was running spot on.
 

Attachments

·
Registered
Joined
·
57 Posts
Discussion Starter #9
CAB said:
EGR exhaust gas recirculation valve.

photo attached to show what it looks like it's between rear of engine and bulkhead on passenger side, remove engine cover and follow silver pipe to the back of the engine and pipe is attached to the egr.
Dealer quoted £240 for valve alone. I found one on ebay new and original part for £110 and fitted it myself.
As for the engine man light to be honest I aren't sure, my light wasn't on initially when I found the fault with planet but I cleared the fault and after driving for a minute or two I got light on and depollution system faulty but car was running spot on.
Thanks for the info Cris, I will see how it goes and if not gone out I will look at gettin it diagnosed. Might get in touch for help if it is the egr if thats ok. Was it relitively easy to fit?

So when you changed the egr had the light gone out or did you need to clear the fault code again?
 
C

·
Guest
Joined
·
0 Posts
Yeah if you need any help/advice don't hesitate to get in touch.

It was a bit of a pig to change compared to the one I did on the wifes vauxhall the other year. But if you take your time and go carefully you can't go wrong.
As I've got planet I turned the light off after fitting the new valve so I knew eveything was ok. Three weeks later and several hundred miles all is fine.

YOU COULD TRY CLEANING THE VALVE FIRST TO SEE IF IT MAKES A DIFFERENCE BUT IT WILL NEED REMOVING TO DO THIS.

Cris.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #11
Got the AA out eventually who found fault code P0234 Turbo overboost. Not really sure what had happened or why?? He reset it and (fingers crossed) it hasn't come back on. So i'm hoping that it was just a blip that won't return. Highly annoying that the light stayed on though when there was clearly no continued fault there.
 

·
Registered
Joined
·
1 Posts
depollution fault peugoet 407 coupe 2008

i had this alarm when i was filling fuel at first point , this may be due to low pressure of fuel after i got this alarm the combustion was like 5 percent and vehicle was not smoothly running , what i did is after i reach the office of 20km i made idle run of the vehicle to fill the fuel in the line .. then alarm disappers ,,..... few u get in my case yu no need to worry about it .. tq
 
1 - 12 of 12 Posts
Top