Peugeot Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello there ..
Im new to this forum & i hope that someone will help me with my pegout 407 problem

today when i was driving my car suddenly warned me with "DEPOLLUTION SYSTEM FAULTY" !!
anyone has experienced that with the 407 ..
please, if anyone did so just inform me is that a serious problem ..
can i drive along the highways.. ?

i appreciate ur help all

thank u :)
 

·
Registered
Joined
·
38 Posts
I have had this several times on my 607. Each time it’s happened the engine slightly misfired on start-up from cold. And the De-Pollution Fault light came on and went into 'limp' mode. The engine management light does clear after 3 engine starts and the fault is logged in the memory. Mine was due to faulty spark coil packs, these were replaced and it’s not happened since.. Touch wood!!

Hope this helps :thumb:
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Oh thank u very much for ur help ...
but im soooo worried even to drive to my dealer coz its too far from where i live .. so is it safe to drive or not n hw much fast shall i drive :confused: :(

Mi H
 

·
Registered
Joined
·
38 Posts
Mi H said:
Oh thank u very much for ur help ...
but im soooo worried even to drive to my dealer coz its too far from where i live .. so is it safe to drive or not n hw much fast shall i drive :confused: :(

Mi H
Hi

I was told by Peugeot in Blackburn.. 'dont worry, nothing will be damaged if you drive it with the warning light on' So I did, and it appears to be ok! You couold just ring your garage to put your mind at ease :thumb:
 

·
Registered
Joined
·
13 Posts
Is it a petrol or diesel?

Assuming its a diesel it could be one of many things. I have heard of a whole range of things causing this error from clogged particulate filters to knackered turbos to simple split rubber hoses. I personaly had this message and limp mode on my old 406 coupe HDI when the differential pressure sensor packed up. the DPS is the sensor that measures the pressure drop across the particulate filter and hence the car knows if its clogged.

On petrol cars i have heard that dodgey coil packs and spark plugs cause it by allowing un-burnt fuel to go down the exhaust. The lambda sensor picks this up and the ECU flags up the message.

Basicly it could be anything but it is more than likley safe to drive, its only an anti-pollution system that is the problem after all. I'd like to think that if it were anything dangerous the engine wouldn't start at all.
 

·
Registered
Joined
·
2 Posts
jameshobiecat said:
Is it a petrol or diesel?

Assuming its a diesel it could be one of many things. I have heard of a whole range of things causing this error from clogged particulate filters to knackered turbos to simple split rubber hoses. I personaly had this message and limp mode on my old 406 coupe HDI when the differential pressure sensor packed up. the DPS is the sensor that measures the pressure drop across the particulate filter and hence the car knows if its clogged.

On petrol cars i have heard that dodgey coil packs and spark plugs cause it by allowing un-burnt fuel to go down the exhaust. The lambda sensor picks this up and the ECU flags up the message.

Basicly it could be anything but it is more than likley safe to drive, its only an anti-pollution system that is the problem after all. I'd like to think that if it were anything dangerous the engine wouldn't start at all.
Could you tell me if changing the dps sorted this we have had probs with our 406 hdi and have just changed the downpipe with cat and still having problems the car jst seems to judder every now and again!!! Any advice would be great, Thanks
 

·
Registered
Joined
·
3 Posts
Hamido

I am facing the same problem now, u can drive it normaly i was afraid at the begining but i called the dealer and they told me not to worry....although they didn't know the reason behind the error msg but i drove the car for more than 5 days with this on, nothing happened. my car is now at the dealer's to be fixed, if u have any suggestions let me know please, they said they changed the spark plugs but i am still facing the same problem, so they are checking it again...sometimes the car starts to shake as if its going off...i keep on pressing on the fuel pedal till it goes back to normal..
 

·
Registered
Joined
·
1 Posts
Depollution System Fault

I driving when i felt a jerk, this warning light came on and My engine died. turns out, my timing belt was torn. have to tow it to the workshop. not a happy man. my car is a 607
 

·
Registered
Joined
·
1 Posts
I am facing the same problem now, u can drive it normaly i was afraid at the begining but i called the dealer and they told me not to worry....although they didn't know the reason behind the error msg but i drove the car for more than 5 days with this on, nothing happened. my car is now at the dealer's to be fixed, if u have any suggestions let me know please, they said they changed the spark plugs but i am still facing the same problem, so they are checking it again...sometimes the car starts to shake as if its going off...i keep on pressing on the fuel pedal till it goes back to normal..
did you fixed the problem?
 

·
Registered
Joined
·
2 Posts
407 cc v6

i have the same issue but every time the msg appear the car start to shake i thought it was because the engine mounting so i change them all but i still have the same problem (shaking) after the msg appear ....
so any help
 

·
Registered
Joined
·
2 Posts
407 cc v6

i have the same issue but every time the msg appear the car start to shake i thought it was because the engine mounting so i change them all but i still have the same problem (shaking) after the msg...
 
1 - 12 of 12 Posts
Top