Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hi all hope someone can help thanks. 307cc 2ltr diesel 6 speed. Depollution system faulty and engine management light came on. Noticed car was struggling up a hill when this happened. Looked it up said to give it a good run on motorway and 4th gear. Did that then went to mechanic, cleared the fault to see if it workex and did for a day or so. Fault came back but also car is jerking through 1st to 3rd gear and definitely using more fuel. Any ideas. Mechanic isn't sure. He rang Peugeot they don't seem to be sure either.
 

·
Registered
Joined
·
296 Posts
When a mechanic doesn't know ? does that make him a fitter ?

As above could be lots of possible solutions /. every case is different

Thought mechanic would have had his fingers in the turbo
mentioned egr valve ?

reference Italian tune up


Think I would try mechanic in a tin ?
Wynns EGR cleaner

then report back ?
or try a different garage for second opinion ?
 

·
Registered
Joined
·
1 Posts
I have 207 and have the same problems been on the garage more than on the road last time was this christmas broke down the rac came out found 5 faults he said it may be a faulty sensor put a new one in its been just over a month and the fault happened again today.
 

·
Registered
Joined
·
11 Posts
I had similar prob. Had 307 2l petrol serviced, OK afterwards. Same diagnostic report and jerky running 2 years later, after a service fine again.
 

·
Registered
Joined
·
2 Posts
I had this on my 2.0 HDI and it was the turbo copy sensor (pain in the ass to get to) I had the take off the left side engine mount and drop the engine forward to get to it. like everyone else said though plug it into planet first!
 
1 - 6 of 6 Posts
Top