Peugeot Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hi! new guy , but probably old problem. got a 2003 , 307 2litre petrol with "depollution system faulty" message on screen display. car running like a pig with flu.had diagnostic , and been told its a crank sensor fault. would that be crankshaft position sensor? or is there another sensor on the crankshaft as well? the mechanic cant seem to give me a straight answer ,(to be honest , not sure he knows himself) and after reading a lot of comments / problems with peugeots of this type , hoping somebody can point me in the right direction . heres hopin!
 

·
Registered
Joined
·
134 Posts
sensor

hi,,yes its on the crankshaft.
i doubt it's the sensor tho,why did he say that??

toddy
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 · (Edited)
toddy2 said:
hi,,yes its on the crankshaft.
i doubt it's the sensor tho,why did he say that??

toddy
when he ran the diagnostic , it read crank sensor , but he didnt give me a code or owt. Would that make the engine judder when idling?
 

·
Registered
Joined
·
196 Posts
it could be a number of thing m8, if you post were you from someone might have a pp2000 near you to plug it in,it don't normally come up with antipol with a crank sensor
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
know what u mean mate , but why would diagnostic find that fault? (no offence intended) , had this problem on and off since the weather turned REALLY cold b4 christmas. Talking starting it up and going to work at 4am in minus8/9 when it started . then a day later runs like new. Fires up first time every time, noticed no difference in fuel consumption, oil,fluids,etc., sparks(apparently)fine , no other issuesreally, could it be injectors? or god forbid the cat?
 

·
Registered
Joined
·
196 Posts
they just make sure everything in sync,if you had pp2000 or access to pp2000 it would show up if its working like it should.the cmp is on the top of the engine mine went wrong i took it it out and it was really dirty.just slackin the spline remove carfully clean it.but some code readers read and give false reading.what area are you from
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
bigboots said:
they just make sure everything in sync,if you had pp2000 or access to pp2000 it would show up if its working like it should.the cmp is on the top of the engine mine went wrong i took it it out and it was really dirty.just slackin the spline remove carfully clean it.but some code readers read and give false reading.what area are you from
update on problem. got my head under the bonnet this week with dr.haynes and his big green book ,had atinker around ,found said crank sensor ,carefully removed ,cleaned ,and replaced as suggested , new air filter -oil and filter and spark plugs just for the hell of it all , and...........bingo! no more depollution system faulty message! bin running great all week , no probs ...........but......this morning the shit bat came straight back out and belted me right in the fizzer! now got a slight engine judder exhaust seems as if its blowing a bit (more than before , it always sounded a bit"throaty") and on screen message reads "engine antpollution system faulty". is my motor taking the proverbial or what? or are these possibly connected faults? got a diagnostic sorted for weekend , but a friend of a friend reckons lamda sensor or manifold sensor? . this bitch is starting to cost me brass , being self employed , no motor no work!
 

·
Registered
Joined
·
196 Posts
good old pug;s they are the worst car ever made.i have nearly rebuild engine now,its cost more than any other car i have ever owned.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
the pug bitch

finally got to the bottom of it. new diagnostic , crock! injector 2 fault . only its not . its injector 1 thats faulty. and the ignition coil. job done , back to normal.....................................for now
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
fixed it!

cheers to everybody for all the info , great site! finally got to the bottom of the problem after reading other peoples problems/solutions. all it takes is a bit of detective work , some head scratchin and loads of good advice. CHEERS GUYS , NEXT ROUND ON ME!!!!
 
1 - 12 of 12 Posts
Top