Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi. Last week radiator fan stayed on with engine off. Has happened 3 times. Later in the week car started and revs idle at 1500-2000 rpm. Car does not always start first time. Depollution error comes up.
Diagnostic shows error code p0609 and P0104. Replaced map sensor and vut sensor and problem still occurs. Also exhaust splutters a bit and sometimes smell of petrol when started. Engine will not drop below 1500 rpm at any point. Still drives ok though. Peg 207 petrol 57 plate. Any ideas chaps?
 

·
Registered
Joined
·
1,805 Posts
What equipment did you use to get the fault codes?

You'll need live data on Diagbox to get a better idea of what's happening under the bonnet.

P06XX codes relate to control modules, so with the P0609 you're almost looking at an electrical gremlin lurking somewhere.

Similarly, the P0104 fault code is described as "Mass or Volume Air Flow Circuit Intermittent". The "intermittent" part suggests there is an intermittent short or break in the circuit.

As for the smell, if the ECU is over-compensating with fuel because of a faulty air mass reading, then this could cause the smell. You might want to check the injectors and plugs too for leaks.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi thanks for the reply. I am not sure what equipment was used as a mechanic did it. I was hoping for a quick fix as need my car for work and am away for a month from Sunday. I am going to leave the car with my mum and get a local garage to try and fix it while I am away. Just hoping it does not die in the next few days. I was also told the cam belt is not sitting flush and needs replacing. He quoted £300. It's all a bit of a nightmare really.
 
1 - 5 of 5 Posts
Top