Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I have a 2006 407 1.6hdi sw with basically loads of warning lights. The abs/esp lights are on along with the de pollution warning. Obd2 plugged in and codes p1351 and p0238. I hate this car now and im thinking of a change poss this week however can anyone help im in kilmarnock scotland and round the corner from arnold clark peugeot but do not want to use them. When de pol light comes on there is a loss of power but only for an instant.
 

·
Registered
Joined
·
6 Posts
1.6 HDI De Pollution DPF and ABS/ESP problems

Hi, the 407 DPF problems are well documented on this forum. My twopenny worth... I have a 1.6 HDI and bought it with the ABS/ESP and DPF lights showing over a year and 25,000 miles ago. Firstly The ABS/ESP light .... turned out to be the combination of speed sensor and the ABS ecu. I managed to obtain a second hand ECU for £80 on-line (247spares.com from memory) the speed sensors can be bought new for around £25-30 a good source for all new parts in my experience is Car Parts Online, Spare Parts, Motor Spares from CarParts4Less.co.uk, labour for all fitting was £50 from a work at home mechanic (probably 3-4 times that if you take it to dealer). Last month it came up again and it was just another sensor (total cost £77), as you will gather the sensors are a common problem.

The DPF problem .. depends how fussy you are, after looking in the various forums here, I decided to ignore it, a year later the car runs as well as it did when purchased now with 141,000 on the clock. In a year of motoring these are the two main issues I have had with the car. I have just bought (this week) another 407, this time an SW executive, as I have been so pleased with the cars economy, comfort and reliability.:)
 

·
Registered
Joined
·
1,073 Posts
The P1351 indicates that you have a fault on either one or more glow plugs, or the glow plug relay. The lack of proper glow plug operation will cause problems with regenerating your diesel particle filtre and this might clog up.

So get the plugs checked over and change defect ones or defect relay in case of that.

The P0238 error is related to the turbo overboosting. Can be something related to turbo electrovalve (or maybe the turbo vanes sticking?). The overboost indicates that there's vacum in the system, as the turbo variable vanes operate such that they give maximum boost when there is vacum in the actuator.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #5
Strange puff puff noise coming from engine today.popped the bonnet and noticed fumes coming from under engine cover. Once off it appeared to be coming from an injector.And allen bolts loose. Now tightened and no puff puff. Maybe issue with depollution fault. I have had this before which i forgot about different injector though.
 
D

·
Guest
Joined
·
0 Posts
Chane the heater plugs and that p1351 will clear.
P0238 is a turbo boost problem. It can be alot of of things from turbo itself or a vacuum problem.

Sent from my GT-S5690
 

·
Registered
Joined
·
21 Posts
I've got the same fault codes on my 407. I did discover that the previous owner or their mechanic had been playing around with the pipe that I think links the air filter to the turbo. The screw operated ring that clamps the two pipes together had been overtightened and there was a gap clearly visible. See attached image I've circled what I'm referring to.

Since I loosened the screw, I haven't had the problem re-occur. So maybe you should check this and pipes in this area?

I was in fact trying to get to replace the glow plugs when I identified this issue. But then got stuck trying to remove the air filter as it is too big to come out :confused:
 

Attachments

·
Registered
Joined
·
46 Posts
Discussion Starter #8
im getting planet and should have it monday/tuesday this week. so we will see what it says. not had de pollution light for a few days now as im not putting too much foot down right now. ill will update when planet is used if i can make sence of it
 

·
Registered
Joined
·
16 Posts
Strange puff puff noise coming from engine today.popped the bonnet and noticed fumes coming from under engine cover. Once off it appeared to be coming from an injector.And allen bolts loose. Now tightened and no puff puff. Maybe issue with depollution fault. I have had this before which i forgot about different injector though.
I am experiencing the same issues as you. Depollution error, chuffing noise, allen bolts loose, oil/diesel leaking from injector #1.

I tightened them up and the car seemed to drive much better, EML soon went off after.

However, whilst going up a steep motorway hill in 5th, I got speed control system faulty message, depollution system faulty message and limp mode. Pull over, switch engine on/off and car drives normally again.

I can feel air escaping from injector #1 when i put my hand directly over it, so I believe this is causing the issue. I have bought injector seals today at a cost of £27 and hope to get these fitted next week - will let you know how I get on!
 
1 - 10 of 10 Posts
Top