Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
2004 1.6 HDI 110. is what my car is

I got my car running after wacking petrol through it. In the end the tops of the stick things had to be removed and new seals put in there. i think they where called injectors. Anyway the car was livley has hell and was going alot better than it was before actaully. Anyway now to my new list of problems.
I was driving it earlier and it was really really slow i think my mums mobility scooter was quciker to be honest. on lift off when its going its not to bad but max speed your get out of it is around 70 ish give or take. I took it to my ex fella and he came up with these fault codes.

ENGINE ECU

Permanent Fault. Turbo pressure regulation Turbo pressure measured to low
Permanent Fault. Cylinder Regerence signal no signal
Permanent Fault. Engine cooling function intergated into the engine control unit. Open circuit or actuator malfuntion
Remove Permanent fault. Engine torque sent on the CAM incorect
Permanant fault. Particle emission filter upstream temprature signal temprature to low
Permant Fault EGR valve circuit. Low EGR repear Raw signal

That lot to me means nothing could someone please give me some help on where to start to look.. I will tell you what was done.

My Ex cleared all the codes and the only one that comes back straight away is the Last one. The EGR has a plate over it as when the plate is not there it will not run you have to remove the long pipe thing going to the stop for it to run. but I been told thats not the reason as alot of people blank them off.
After you drove the car lets say about a mile all the other comes back.

The battery was taken off for around 30 mins and then put back on

i would be very greatful if someone has some idea on where to at least start so i can tell the people who are looking at it.

The car i got is a 2004 1.6 HDI 110.
 

·
Registered
Joined
·
4,506 Posts
Sounds like a few connections may have been forgotten, or plugged into wrong ports. Ask the fella who did the seals did he remove any electrical connections etc. Although since you did run petrol through a diesel you may have also knackered the exhaust system. Fingers crossed your turbo is fine.
 
1 - 2 of 2 Posts
Top