Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5,906 Posts
Discussion Starter #1
2004 307 2.0L S HDI 90 (VAN/CAN system)

Help me please - Has anyone any ideas as to why cruise control isn't working ?

Fitted the cruise control stalk which was working perfectly well in my last car then using planet, went into the engine ECU and set Speed Control to Present. Next went into BSI / Configuration / Customer Options / Miscellaneous and set cruise control to Cruise Control type 2 without limiter. The stalk is cruise control with limiter.

Selecting Type 1a or 1b does nothing at all - nothing on the display and no cruise control. Even tried setting it to type 2 with limiter with no joy.

Driving at 50MPH in 5th gear, switch cruise on and the display shows Cc & Off. Pressing the + or - buttons switches cruise on and displays the set speed but then goes off after about 1 second. The display now shows Cc / Off & --- (three dashes).

Thought it might be the brake switch so bought and fitted a new switch (It's the 4 wire black body with white connector) but no change. Set the cruise to on, displays the set speed then switches off with the 3 dashes.
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #3
Just been out and tried the BSI reset and it's still the same.

Does it matter whether you turn on in BSI before the engine ecu or vice versa ? Wouldn't have expected it to make a difference but stranger things have happened.

I know that cruise control was available on this model and being that the com2000 had the connector, the bsi & engine ecu have the options in there and the fact that Cc displays when switching cruise on gives the impression that it should work.

Is there a clutch switch that may be faulty as it has to have some information that the clutch has been depressed to turn cruise off. If that was missing / faulty then it would be a good reason why it doesn't work. Maybe even something to do with the accelerator pedal ?

I'll be a bit disappointed if I can't get the cruise working as I use it a lot going to work early doors.
 

·
Registered
Joined
·
5,906 Posts
Discussion Starter #5
YAY - I now have Cruise Control working. Should have realised what the issue was as when I was looking for a car, I test drove one about the same age with factory fitted cruise and that didn't show anything on the display.

It's not really a big issue not having the display so I'm now a happy bunny.

The first time I tried setting cruise to type 1 (variant A) it didn't work so the brake switch must have been the reason why.
 
1 - 5 of 5 Posts
Top