Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi to everyone.

It's my first post here and I hope you can help me please.

I would like to have cruise control added to my 2009 Peugeot 207 1.6 HDI S.

Is there a place where I can have this retrofitted in the Bournemouth area? I contacted the Peugeot dealer here and they advised not to and it's something they didn't do.

Many thanks
Gregor
 

·
Registered
Joined
·
6 Posts
Hi there,
I am also new here but I have done a lot of digging and have found that you only need to install the cruise stalk and then enable Cruise in your ECU.

Here is a YouTube video showing how to install the stalk
youtube[dot]com/watch?v=_xmnUgV407w

And here is a list of member that have Peugeot Planet and can do the activation for you.
peugeotforums[dot]com/forums/maintenance-9/diagnostic-peugeot-planet-map-7734/

Hope this helps!

Garry
 

·
Registered
Joined
·
6 Posts
Hey,

Just to give you some more info, you can buy the cruise stalks from eBay.

Here is an example listing but you may be able to find them cheaper...

Have a look around!

ebay[dot]co[dot]uk/itm/Peugeot-207-208-307-406-407-607-807-Partner-Cruise-Control-Unit-with-Limiter-NEW-/251961430642?hash=item3aaa125272

Garry
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Many thanks

Hi Garry and Planet Diags: Cheshire, Merseyside, Flintshire

Many thanks for your replies - they are very much appreciated.

I'll order the part and hopefully find someone to activate the cruise control

Many thanks again
Gregor
 
G

·
Guest
Joined
·
0 Posts
Hi Gregor - PM sent :thumb:

The Peugeot Dealers ( Westover I presume ) are good for spares, generally very helpful but maybe they don't want the hassle?

Feel free to contact me so we can get the cruise sorted ( hopefully... )

I've tried to find a replacement cowling on-line but no joy yet - we may need to cut a slot in your existing cowling.

Kelv.
 
G

·
Guest
Joined
·
0 Posts
All sorted, Gregor now has working Cruise Control on his 207 :cool:

I did make a couple of errors while setting the car up - the stalk was a Cruise/Limiter type so I activated the limiter functions as well as the cruise functions, which didn't work - the cruise just wasn't activating at the correct gear/speed.

Then I disabled the limiter functions but kept the cruise enabled and this did the trick, something I must remember in future :thumb:
 
1 - 8 of 8 Posts
Top