Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello,

I decided to retrofit cruise control to my 54 plate 407 S spec car. I've read many of the threads on here on how tos etc but when I try to set the speed the 3 dashes just flash.

My cruise stalk can also limit the speed.
I've replaced the brake light switch.
I've tried all available options in the BSI.
I've activated cruise control in PP2000 too.
I haven't got any cruise related faults on PP2000 either.

Can somebody tell me what i'm missing or done wrong?

Thanks,

Phil
 

·
Registered
Joined
·
496 Posts
When in engine ECU with planet are you sure you have selected the correct ECU variant for your vehicle? You usually get a few options. The first 3 digits of the selected variant (example RHY or whatever it is followed by BOSCH etc) must match up to positional digits 6,7 and 8 (these are letters) (example RHY) in the middle of your VIN number. I am only mentioning this as I have fallen foul of it myself when activating CC for someone else.

The video below may help to suss if you have missed anything, it is for a 406 but the principles should be similar.

https://www.youtube.com/watch?v=cokOR5cuYUA#t=90
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Appreciate the help Wayne.

Thats the video I used to activate the cruise control with but I never got the option to choose ECU type it just automatically found it.

I've measured the clutch switch and I'm getting a reading of ~150 so i imagine that is at fault.

Thanks
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Yes I've got four wires to the brake light switch which i've replaced thinking it was faulty.

Cheers

Phil
 

·
Registered
Joined
·
496 Posts
The speed limit function can somewhat complicate installation, I would always recommend buying a stalk with CC only not speed limiter. If you put it back on planet and choose cruise control stalk without speed limiter, there's a possibility of at least the cruise control working (but not the speed limiter).
 

·
Registered
Joined
·
14 Posts
Hello,

I decided to retrofit cruise control to my 54 plate 407 S spec car. I've read many of the threads on here on how tos etc but when I try to set the speed the 3 dashes just flash.

My cruise stalk can also limit the speed.
I've replaced the brake light switch.
Cruise control need: clutch switch AND brake switch (4 wires).

Limiter need: special pedal accelerator OR one resistor 6k5 ohm in PSF (but exceeding the set speed limit by pressing beyond hard-spot is not possible).

Activate in PP2000 in two places only: BSI and ECU.
 
1 - 8 of 8 Posts
Top