Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hi everyone,

I have a 04 2.0 90bhp SW 307

Sorry if this is a stupid question but i am scratching my head, when should the fan come on, my assumption has always been it should come on once the engine has reached temp?

The reason i ask is i have let the engine warm up and it went a bit over 90 then appeared to come down, but still cannot see the fan working....i have a funny feeling im being really dim somewhere?

I have done a full service on (oil,air pollen and fuel filters ) it including the coolant, i followed the process in the haynes manual and bled the system using the bleeder at the thermostat housing i could not find the second bleeder on the heater hose bulkhead connection and is now at the correct level.

Im really confused as to whats going on as the car has not yet overheated or gone anywhere near the red.....i would have thought this would have happened if the fan is not working at all?

Many thanks
 

·
Registered
Joined
·
1,805 Posts
Hi everyone,

I have a 04 2.0 90bhp SW 307

Sorry if this is a stupid question but i am scratching my head, when should the fan come on, my assumption has always been it should come on once the engine has reached temp?

The reason i ask is i have let the engine warm up and it went a bit over 90 then appeared to come down, but still cannot see the fan working....i have a funny feeling im being really dim somewhere?

I have done a full service on (oil,air pollen and fuel filters ) it including the coolant, i followed the process in the haynes manual and bled the system using the bleeder at the thermostat housing i could not find the second bleeder on the heater hose bulkhead connection and is now at the correct level.

Im really confused as to whats going on as the car has not yet overheated or gone anywhere near the red.....i would have thought this would have happened if the fan is not working at all?

Many thanks
Depends what model you've got, as there are different types of fan.

In short, the main cooling fan should come on at full speed once a certain coolant temperature is reached.

The relays are prone to corrosion on the pins, meaning they won't work correctly. But, there are other reasons for the fans not working.

If you want to do a quick test, unplug the temp sensor with the engine running. If the fan is working properly, it should kick in as a fail-safe once the sensor is unplugged.

Or, you can perform an actuator test on PP2000 if you have access
 

·
Registered
Joined
·
1,111 Posts
The engine has to get pretty damn hot before the cooing fan will cut in, something like 110 degrees. If the car is exposed to a stiff breeze that might well be enough to prevent the fan from coming on, even in this weather.
However it should come on after idling in a garage for a long time. Run it at a fast idle to sped up this process. A quick and dirty test if you don't have access to the proper test equipment is simply to run a wire to the fan to see if that kicks it in.
But I do think you may be looking for a problem you don't have.

Roger.
 

·
Registered
Joined
·
15,114 Posts
On a good well matched cooling system in good working order the cooling fan will NEVER come on !!

Cooling fans are there to assist the cooling system in exceptional conditions not duy to day running.

If you have aircon and it works ! put it to max cold and your cooling fans should then come on if they do they are fine.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Thanks for all your replies.

Well after quite a long drive today never saw the temp rise above 90c so perhaps i am worrying about nothing. I think the problem maybe the AC is not working all that well currently which is also causing me concern, but have an ac specialist who i trust coming out to look at it tommorow fingers crossed its only a regas, as the car appears to be running so well and like the looks of it!!

Therefore when the ac is on i cannot see the fan running and have never seen the fan running. So technically if the ac is on and working which hopefully it will be tommorow the slow speed on the fan should be working?

I have a basic OBD and i checked the temperature reading live data and it matches up with the one on the temp gauge but that doesnt really tell me anything.

Thanks, will see what happens tommorow.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Well today i found out the airconditioning was not working due to a holes in the condenser. I will change the condenser and recharge the system and see if the fan comes on when the ac is on.

At the end of the day ive done quite a few miles now and left it at idle and has not overheated so am not overly concerned at the moment
 
1 - 7 of 7 Posts
Top