Peugeot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi guys
2005 407 SV
The computer display is perfect when cold but after half an hour or so it goes weird and you can't read anything on it, just lots of lines etc.
I can get a replacement from a local breaker. It's coming from a 2006 407 SE model. Is this a plug and play or is it more complicated than that?
 

·
Moderator
Joined
·
5,115 Posts
common fault, as long as both cars have same climate control/radio etc its plug and play.
How much you paying from breakers ?? as some on the facebook page are getting new for £27 i think.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
common fault, as long as both cars have same climate control/radio etc its plug and play.
How much you paying from breakers ?? as some on the facebook page are getting new for £27 i think.
Cheers trem1, thanks for your reply.

New for £27???? The breaker is asking for £20, if I can get a new one for that it would be silly not to. Do you have a link?
 

·
Moderator
Joined
·
5,115 Posts
Cheers trem1, thanks for your reply.

New for £27???? The breaker is asking for £20, if I can get a new one for that it would be silly not to. Do you have a link?
No link but I'll try and find one for you

Sent from my K013 using Tapatalk
 

·
Moderator
Joined
·
5,115 Posts

·
Registered
Joined
·
1,140 Posts
I would be extremely dubious of any second hand unit having any sort of longevity as every 407 I have come across has either an unreadable one or has had it replaced.

I replaced the display in both my 407's with ones got off ebay. Paid USD77 for both including shipping to NZ. But had to program them with my Lexia kit as they came unprogrammed. Easy job, took about 5 mins to do once I had worked out what process to use.
 
1 - 8 of 8 Posts
Top