Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1 (Edited)
Hi

I have the dreaded "Intermittent Speedo" problem.

I believe I will try the unit on the gearbox first.

I have a new unit but the replacement procedure has become quite complicated for a few reasons.

The area where the unit is located is caked with grease / grime so much so I struggled to even see it! I have tried cleaning it with Switch Cleaner and manually with a brush and although it looks better it is still quite bad. I realise there is a small oil leak at the valve cover gasket right above the control unit. This obviously being the reason for all this gunk.
The car is a beauty and I have spent many hours cleaning her inside and out. The engine bay is pretty spotless except for those hard to reach places... as with this speedo unit.

The thing is that I don't want to remove the old unit with all this grime around in case some of it falls into the cavity the unit sits in.

I can't seem to get the plug off either. I have squeezed it and pulled but to no avail. It is so hard to do anything from the top so I will have to do it from the bottom but I first have to unsrew the little bolt remove the unit and then unclip the plug and put the new one in but obviously it has to be very clean surrounding the control unit.

Does anyone have any ideas that could help?

I am tempted to just use some Engine Cleaner and carefully spray that specific area off manually with a garden hose by but am naturally nervous to get any water near a PUG engine.

Please help! :)

Thanks guys!

My PUG is a 2001 406 2.0 16v Sedan with Automatic Gearbox
 

·
Registered
Joined
·
14 Posts
Don't be too afraid with a bit of water.

What i would do: place a flat bowl under the car, use some Dasty degreaser, an old dishwashing brush and a plant spray bottle filled with hot water to clean up only the dirty parts.
 
1 - 3 of 3 Posts
Top