Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone, my name is Pablo and i own a 1979 Peugeot expert 1.9TD van, and live in Swindon.

The clutch cable plastic at the pedal end snapped, so i made a metal one to go over it, as photo below.
This worked ok for a day or two, but it has gone again but this time it has not snapped as i have the metal retainer over the plastic so it is still on the pedal.
I took the spring off the clutch pedal and it does spring up when i press it down, but i have no clutch, so is the cable snapped or is it something else.

I don't want to spend £62.00 on a new cable if it isn't the cable that has gone, so can anyone please shed some light on this for me as i urgently need the van for my carpentry & maintenance work.

Any help at all would be very much appreciated.
Pablo.

 

·
Registered
Joined
·
15,377 Posts
There is a self adjust built into the cable and these can fail but as said above your clutch itself or the pivot on the bellhousing needing greased may be the reason for the cable failing
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks reliable406, will also look at that in the morning and let you both know the outcome.

All the best.
Pablo.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Another question sorry guys.
I have not done a clutch cable on this before, so is there anything you can tell me about the removal and refitting procedure as i dont have a clue where to start.

Thanks guys.

Pablo.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Thanks For The Help Guys

Hi again guys.
I had to buy a new cable in the end and installation is pretty simple, and everything went smoothly and the van is back on the road.
Again, i would like to say thanks to the guys that did help with suggestions etc, you are awesome.:thumb:

All the best.
Pablo.
 
1 - 7 of 7 Posts
Top