Peugeot Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am aware of the other thread about the clicking noise, however mine doesn't seem to be electrical sounding. I would appreciate any help in finding out why I have an annoying clicking sound coming from around the steering wheel (around the right hand side from what I can tell). It kind of resembles the noise of a computer mouse clicking and there's nothing I can link the sound to.
Any help getting to the bottom of this would be greatly appreciated!
 

·
Registered
Joined
·
184 Posts
I took apart my comm2000 at the weekend to attempt to do something about the indicator issue. I ended up making it worse so am gonna replace it next week.

Reason I bring this up is before I played around it was fine (apart from the indicator), but now it also clicks on turning, kind of like you describe, computer mouse, a plasticy clicking sound. I kind of know what it is but its difficult to explain, for me the only way I will get this fixed is by replacing my comm2000 unit.

Does it only happen when turning the wheel?
 

·
Registered
Joined
·
184 Posts
bettyswollocks said:
Did you make sure and count the turns before putting back on .

http://www.peugeotforums.com/forums/showthread.php?t=7234
I didn't go by your guide as I didn't look first. But I basically did the same idea, counted the rotations at each full extent and then met in the middle. It hasn't snapped so I think its ok. But I found it a royal pain in the arse to get the cover to stay on when you join the 2 parts back together. Everytime I would snap it shut the plastic cover on the flex cable rotator thing would pop up.

The joke is I took my mates apart last week but got that back together no problem whatsoever. Indicators are still fubared though, lol. Gotta buy one off a breaker now
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
It's not related to when I turn the steering wheel.. It's weird because it didn't click today, I'm thinking maybe it's something to do with me putting the wipers on? I'm hoping it'll randomly go away unless someone has any other ideas that doesn't involve replacing anything because I'm completely useless with cars!
 

·
Registered
Joined
·
184 Posts
If its to do with the wipers then wiper relay could be the culprit.
Clicking a lot of the times is down to a relay if its random.

As you say it happens more with the wipers and they do have a relay in then that suggests it could well be that
 
1 - 7 of 7 Posts
Top