Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Hi all,

Has anyone come across an issue where the speed limit in the red circle on the sat nav is different on the central display?

An example would be that I drive home from work. The sat nav correctly displays it's a 60mph zone but the display between the dials displays 37mph. The odd thing is that it's only on my way home! On the same road but driving towards work it shows the correct speed.

I'm confused as I thought the central display would mirror the main screen!
 

·
Registered
Joined
·
56 Posts
Discussion Starter #3 (Edited)
Do you have sat nav? Mine displays the speed limit on the nav screen and also in the central display. It's on the right of the current speed.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
542 Posts
Mine has same display as socktug. I've had mine give me random speed speed limit displayed. I've noticed the display shows no entry for roads wrong when giving directions for sat nav. It seems to think you are in LHD car...:)
 

·
Registered
Joined
·
56 Posts
Discussion Starter #8
Mine has same display as socktug. I've had mine give me random speed speed limit displayed. I've noticed the display shows no entry for roads wrong when giving directions for sat nav. It seems to think you are in LHD car...:)
I haven't noticed the no entry issue yet but I've not really driven anywhere that I need to use the sat nav! I'm due a 1000 mile / 1 month service in about 2 weeks. I'll ask the dealer then about the random speeds displayed. It's odd though that the nav displays it correctly but the central display shows its own random speed. I mean 37mph is not even a recognised speed limit!
 
1 - 8 of 8 Posts
Top