Peugeot Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hello Friends!

I had changed the center display from the red monochrome to coloured one. It is nice and every data working and displayed fine. The only problem is that i can not use the scroll button on the left side of steering wheel, and I can not use the config menu.
Somebody told that I need to reprogramm the BSI with diagbox to learn the new display.

Do anybody has a routine in this procedure?

Please tell me what to do
 

Attachments

·
Registered
Joined
·
500 Posts
Hello Friends!

I had changed the center display from the red monochrome to coloured one. It is nice and every data working and displayed fine. The only problem is that i can not use the scroll button on the left side of steering wheel, and I can not use the config menu.
Somebody told that I need to reprogramm the BSI with diagbox to learn the new display.

Do anybody has a routine in this procedure?

Please tell me what to do
Did you source the newer display from a newer face lift 508..?
You may need to change the configuration in the instrument panel to suit the newer display..
Ron.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Did you source the newer display from a newer face lift 508..?
You may need to change the configuration in the instrument panel to suit the newer display..
Ron.
Hello Ron!

I'm using the right display (before facelift)
How can I change any configuration if I can not reach the config menu? This is the primary and only problem.
 

·
Registered
Joined
·
5,928 Posts
Hello Ron!

I'm using the right display (before facelift)
How can I change any configuration if I can not reach the config menu? This is the primary and only problem.
There is usually a choice of display types when you go into the display configuration using diagbox. You select the appropriate display type, click the button to program the change and hopefully everything will work as it should.

If you don't know the display type then it's a matter of selecting each one until you get the correct one.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
There is usually a choice of display types when you go into the display configuration using diagbox. You select the appropriate display type, click the button to program the change and hopefully everything will work as it should.

If you don't know the display type then it's a matter of selecting each one until you get the correct one.
Dear storeman!

Thanks for your answer

Now I ordered the Lexia 3 and diagbox. I need to learn how it is works, which menu contains the option you mentioned. I will do it asap

Thanks again
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
There is usually a choice of display types when you go into the display configuration using diagbox. You select the appropriate display type, click the button to program the change and hopefully everything will work as it should.

If you don't know the display type then it's a matter of selecting each one until you get the correct one.
Hi

I spent 2 hours but i can not find the option you told. if you have sime time, could you please help me?

regards
 

·
Registered
Joined
·
5,928 Posts
It may be in the MultiFunction Display or the instrument panel options or similarly worded options. I've only done a diagnostic on one 508 and that was to turn off tyre pressure monitor so can't say for sure. I did originally say that there is usually an option. There may not be an option for your requirements.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
It may be in the MultiFunction Display or the instrument panel options or similarly worded options. I've only done a diagnostic on one 508 and that was to turn off tyre pressure monitor so can't say for sure. I did originally say that there is usually an option. There may not be an option for your requirements.
2 another hours, and i can not find the option where to change the type of the matrix display

please, if somebody have a time, tell me step by step

i tried 2 versions of diagbox 7.57 and 7.66 but i can't

I'm close to give up
 

·
Registered
Joined
·
30 Posts
Discussion Starter #12
Hi, did you get it running?
Where did you buy the new display?

BR Christopher
Hello!

It is shows the pages but the config option is still not available. I called few professional mechanic but nobody knows the solution. Strange because it is an original Peugeot 508 part and a friend of mine can use with no problems.

I tried every settings in diagbox but no result. You can check it working here:



I do not know what else can i do

try on bartebben.com
 

·
Registered
Joined
·
404 Posts
Hello!

It is shows the pages but the config option is still not available. I called few professional mechanic but nobody knows the solution. Strange because it is an original Peugeot 508 part and a friend of mine can use with no problems.

I tried every settings in diagbox but no result. You can check it working here:

https://www.youtube.com/watch?v=aIWYegLJcqA


I do not know what else can i do

try on bartebben.com
What year/model do you have?
 

·
Registered
Joined
·
404 Posts
it is from 2013/1. The display is produced for 508 and 208 as well
Did you upload custom software on you system? Is tire temperature and pressure on your middle display standard option?
I know there are scripts that can do this.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #16
Did you upload custom software on you system? Is tire temperature and pressure on your middle display standard option?
I know there are scripts that can do this.
You need to download some files from the RT6, modify on computer and upload it again. fom home i can send you the procedure, now I'm on another computer
 

·
Registered
Joined
·
404 Posts
You need to download some files from the RT6, modify on computer and upload it again. fom home i can send you the procedure, now I'm on another computer
But is this the reason your config button stop working?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #18

·
Registered
Joined
·
2 Posts
Hello,

I also replaced my display with a colored one. For me, everything works perfectly, except for the display of the gears. The top right corner of the display is empty. So the display doesn't show the selected gear and if the car is in sport or winter mode.
I already tried to find an option with diagbox to activate the gear display, but I couldn't find it. Does anyone of you know the problem?

I add a picture to explain the whole thing a bit better:



My car is a 2014 508 180 Blue HDI.

Christopher
 

·
Registered
Joined
·
30 Posts
Discussion Starter #20
Hello,

I also replaced my display with a colored one. For me, everything works perfectly, except for the display of the gears. The top right corner of the display is empty. So the display doesn't show the selected gear and if the car is in sport or winter mode.
I already tried to find an option with diagbox to activate the gear display, but I couldn't find it. Does anyone of you know the problem?

I add a picture to explain the whole thing a bit better:



My car is a 2014 508 180 Blue HDI.

Christopher

Hello!

sorry my late answer. I was on holiday :D

I still not found the solution for my problem and I do not know what is th problem with your one. check this setting in diagbox:



I thought that i will go to the dealer and ask them to reprogramm it
 
1 - 20 of 26 Posts
Top