Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I recently had problems with my cd head unit in my 508 sw 2012 it was intermittent for ages turning on and off all the time, Until it turned off and stayed off,out of use for months, I could hear a light whirring noise coming from the cd like it was trying to start but never did.
You can read my other post headed CD HEAD UNIT.
Anyway I have actually had it repaired it’s like brand new with updated maps +now I can put postcodes in to search and speed camera alerts it’s brilliant I’m really chuffed to bits,phones back reverse sensors back it’s brilliant,
I had a problem with the volume when it arrived back to me when I Installed it back into my car I contacted the repairer (Karim)and he gave me the instructions to get it back and all is fine now.
Right if you want yours repairing this is what I done ,I paid £17.50 to post it to Karim in Spain he received it a few days later he kept in constant contact with me ,he told me it’s been all updated and working fine ,I made another payment of 200 euros about £180 ish ?? He posted it back to me I received it a few days later plugged it all back in and it fired up couldn’t believe it after so long without it.the whole process took around 2 weeks ish .
Karim Dehmous
[email protected]
autotronics.eu | autotronics.eu
 

·
Registered
Joined
·
15 Posts
Thanks for this. Just used Karim myself. Brilliant

I recently had problems with my cd head unit in my 508 sw 2012 it was intermittent for ages turning on and off all the time, Until it turned off and stayed off,out of use for months, I could hear a light whirring noise coming from the cd like it was trying to start but never did.
You can read my other post headed CD HEAD UNIT.
Anyway I have actually had it repaired it’s like brand new with updated maps +now I can put postcodes in to search and speed camera alerts it’s brilliant I’m really chuffed to bits,phones back reverse sensors back it’s brilliant,
I had a problem with the volume when it arrived back to me when I Installed it back into my car I contacted the repairer (Karim)and he gave me the instructions to get it back and all is fine now.
Right if you want yours repairing this is what I done ,I paid £17.50 to post it to Karim in Spain he received it a few days later he kept in constant contact with me ,he told me it’s been all updated and working fine ,I made another payment of 200 euros about £180 ish ?? He posted it back to me I received it a few days later plugged it all back in and it fired up couldn’t believe it after so long without it.the whole process took around 2 weeks ish .
Karim Dehmous
[email protected]
autotronics.eu | autotronics.eu
 
1 - 3 of 3 Posts
Top