Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello all,
Im having trouble with my 307. Its a 2.0 HDI, 53 Plate.
The car has been running fine, until today. I put the key in the ignition, and nothing happened at first. Then after a few seconds the dash lights came on. When I tried to start the car, nothing happened. There was a click from the starter motor. I checked the voltage of the battery, and got 12.5v, which I beleive is ok? The central locking would not work, and when I try the lights, wipers and horn, I hear a rapid clicking noise coming from the Fuse unit in the dash. I have checked all the fuses, and conot find any that are blown.
Can anyone help me?
Thanks for your time.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Dont think it can be the starter motor, as that would not stop the lights, wipers, and central locking working. And the battery showed it was charged. I did manage to get the central locking to work, so at least I could lock it. I have since tried to unlock it, and it doesnt.
 
S

·
Guest
Joined
·
0 Posts
Have you tried a bsi reset, especially after putting new battery in

Put the driver's window down, lift the bonnet and ensure all equipment is switched off.

Ensure all doors are closed and remove key from the ignition.

Wait for 3 minutes, disconnect the vehicle battery and wait another minute or 2.

Reconnect the vehicle battery, wait a further 10 seconds (do not open doors.).

Switch on the side lights through the driver's window.

Switch on the ignition and check system's functionality.

Hold lock button on key down for 10 seconds.

Remove key open & close door test central locking system.

Start the engine and complete the system's check.

Failure to follow this procedure could result in incorrect operation of many BSI related items.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Hi, I tried that yesterday, but that was before the new battery. I will give it another go, see what happens.
Thanks again for all your help
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
It worked!! Not sure now if the problem was the battery or not. It looks old, and alot smaller than the new one.
Anyway, Thanks again for all the help.:)
 
1 - 13 of 13 Posts
Top