Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi. I'm new to this website (forum) and was wondering if anyone can help. I have a 207 Hdi on a '57 plate.

When I start the car, the engine is juddering and literally shaking (as if it's gonna fall out), and the engine sounds like it's choking and going to cut out. I've had the car serviced, the glow plugs have been changed too. Once the car warms up, it seems to be ok, but the last few days it has been doing it whilst warm too. It does it when standing.

I even had it in at the dealership (reluctantly) and they couldn't find a fault (or fault code). Is this something that maybe you could help with, or know of anybody who can?

Any help or guidance would be much appreciated.

On a separate issue, the rear parking sensor is showing a fault. Does anyone know where I can get the sensors sorted (apart from the dealer)

Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks for the replies. It's a 1.6 (110 model). No strange noises except the engine sounds like its gonna cut out, so the idle sounds up and down. As for the engine mounts, they were broken, but have been replaced recently.

I guess the engine mounts were broken prior to me buying the car, hence needed replacing. I bought the car about a year ago (privately) and the problem has been present since then.

It had disappeared for a while thanks to an 'air pipe' being replaced during the service, but has returned with a vengeance!! I have a video of the problem which I can email (if it helps).

Thanks
 

·
Registered
Joined
·
240 Posts

·
Registered
Joined
·
1,912 Posts
Niz hi, on this forum are documented steps for doing an injector leak off test, these can be found via the search box top of page. I would seriously consider doing this as its cheap and easy to do and could well be relevant to your problem.
 
J

·
Guest
Joined
·
0 Posts
Agree with sterion.... I'd also be looking at injectors. Probably wouldn't show a fault (mine didn't) but I had an issue with no.3 which meant the car war idling rough when cold.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Thanks guys. Will take a look and do the necessary tests as requested. Will update once I know the situation.

Update with regards to the dealer problem, they have today collected the car, given me a new 208 to drive, and agreed to diagnose the problem for free, due to their incompetence the first time around. And all this because I complained. So let's see if they find anything this time.......

Once again, thanks to all those who took the time to reply. Much appreciated.
 
1 - 8 of 8 Posts
Top