Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi there I have a Peugeot 307 1.6 16v and a few weeks ago the anti pollution light came on and had it diagnosed by the RAC who told me it was the MAP sensor, I fitted a new Bosch Map sensor to no joy I have since replaced the CAT, Oxygen Sensor Pre Cat, Temp sensor to the ECU and Coil Pack and still it exists.

The car will not idle when cold but have found out if I pull of the plug to the MAP sensor the car will idle and drive but do get a droning through the exhaust. I had another garage look at the fault and he come back and said economical to repair and wouldnt help any further.

Has anyone else had these issues and why does my car run with the map sensor disconnected but as soon as I plug this sensor in the car wont idle right and wont pull away without major hesitation. RAC did also state that there is an incorrect reading going to the o2 sensors but have renewed the pre cat one. Could it be a blocked centre box on the exhaust system causing the sensors to read properly and also causing the droning and lack of power?
 

·
Registered
Joined
·
296 Posts
CALLING ALL PUG TECH MECHANICS ? WHERE ARE YOU ?

Very surprised you haven't had a response from the forum
Sorry Petrol is not my bag of spanners

I assume you have PUG Planet / cleared the codes after repair

I am sure you need to tell the ECU if your have replaced major parts ?


lets hope this jumps this problem back to the top to get a resolution
 

·
Registered
Joined
·
15,376 Posts
Unplugging the map sensor simply disables the controls for some of the fuel system this will make the ecu go to a safe running map it does not mean map sensor is faulty.

Most on here have diesel engines

Common issue on NFU is bad injectors causing missfires rough running etc

Could also be drawing air at various pipes on intake manifold throwing parts at a problem is an expensive way to cure it.

You need PROPER diagnosis not just someone reading codes.
 
1 - 3 of 3 Posts
Top