Peugeot Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1 (Edited)
Hi guys!

Back again looking for some advice!

I seem to have a strange buzzing noise coming from the rear of my car, seems to be back left/middle of car.

I get the noise when,

I turn on the ignition, it usually lasts for around 20-30 seconds with just the ignition on and then stops.

Once the engine is started, the noise is then continuous. BZZZZZZZZZZ.

It really sounds like something driven by electricity like a pump or motor or something.. Strange though, I head my head under the car just now listening to try and locate it (hard when its on the ground) and the the noise stopped for a few seconds and then started again...

I do know the main advice is to get it hooked up to planet but i'm living in Sweden without one close by and can't really afford to pay the £100 for peugeot to do a read for me.

Hopefully someone out there has had a similar problem and could point me in the right direction?

Cheers!
Edd

2003 307 XSi 2.0 petrol
 

·
Registered
Joined
·
60 Posts
Discussion Starter #3
i was wondering if it could be that... bloody sick of this car... im pretty sure its not supposed to be making all that noise... I'll have to get it up on a ramp and have a listen.

Cheers
 

·
Registered
Joined
·
102 Posts
when i turn ignition on my car i can hear buzzing noise so i presume you hear the same noise lol mine is a few seconds then it goes quiet. im not sure if it should do that noise for that long though. bear in mind mine is diesel.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
Righty!

Of course it was under the seat with the baby chair strapped to it...

Defo the petrol pump so looks like i'll have to get a new one asap. if its making lots of noise its probably gonna give up soon so better to get it swapped out. There went £100... at least it looks pretty straight forward to swap out.
 

·
Registered
Joined
·
102 Posts
Righty!

Of course it was under the seat with the baby chair strapped to it...

Defo the petrol pump so looks like i'll have to get a new one asap. if its making lots of noise its probably gonna give up soon so better to get it swapped out. There went £100... at least it looks pretty straight forward to swap out.
may need a good clean pal maybe got some crap in it:thumb:
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
aaah! Thanks mate! I will give that a go, just to check, have you cleaned out one of these before and if so whats the procedure? according to haynes the rubber sealing ring has to be replaced if the pump is removed, you know if I would have to swap out that if I take out the filter for a clean?

Cheers and thanks for the help!
 

·
Registered
Joined
·
102 Posts
aaah! Thanks mate! I will give that a go, just to check, have you cleaned out one of these before and if so whats the procedure? according to haynes the rubber sealing ring has to be replaced if the pump is removed, you know if I would have to swap out that if I take out the filter for a clean?

Cheers and thanks for the help!
haynes always tell you to replace any kind of seal that's just to cover them selves mate if the seal is not cracked and perished its probably ok too put back.

i cant see it being difficult mate just make sure your not smoking anywhere near car once you have broke the seal might be wise to disconnect battery also just for your safety. try doing it when the fuel needle is low. im sure some one will advise you further on here when they see the post:thumb:
 

·
Registered
Joined
·
60 Posts
Discussion Starter #10
Quick update!

After the last post I went out and thought i'd giver the pump a good clean!

Got the carpet up, lid off, fuel line and connecter off no problem!

Then came getting off the black plastic screw fitting that holds the pump in, followed haynes advice and tried to use a screwdriver and hammer to push it around enough to turn by hand and... its stuck solid... (of course)

I gave up in the end and put everything back together, and what do you know, no noise whatsoever after driving the car 10-15 times! (touch wood)

Not sure the reason, maybe disconnecting the power or even the banging from the hammer freeing something that was stuck but problem seems to be solved!

Thanks all for the advice and help, don't know what i'd do without you!
 
1 - 12 of 12 Posts
Top