Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hello,

I managed to get pp2000 working. Car has been running rough and had the ABS issue. I checked and got the following faults:





I took a look at the ABS connector and it was like this:




So I cleaned it up.

Now when I went to start the car, it wont start. It says economy mode. So i tested the battery. Battery at 12.29v. So I fitted a new battery. Now it wont start. Still says economy mode.

When I try to turn it over I hear a click near the gloved box then nothing. I checked the beeps when I leave the key in and open the door and the car does beep so its not a problem with the key code.

Can anyone help me get the car started again?

Thanks.
 

·
Registered
Joined
·
14,628 Posts
None of those faults would stop it starting except underbonnet fusebox faulty possibly

ABS plug is filled with grease when new thats normal.

Economy mode is BECAUSE its not starting not THE cause ignore it.

Explain what you mean by nothing.

You dont say what engine either this is useful.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Ok, Economy mode ignored. TY.

This is a 2.0 Hdi.

Prior to this I was getting intermittent Anti Pollution, and Pre-Tensioner faults all the time.

When I turn on the Ignition I get clicks from under the glove box then no further action. The engine doesn't attempt to start or turn over at all.

Thanks for the quick reply.
 

·
Registered
Joined
·
14,628 Posts
Change your fusebox both the starter circuit and the ABS go through it and replacing the battery may have lost comms through it for good.

Fuse 8 in there is the starter trigger check its not blown but does sound like a fusebox problem.

Rear light is most likely just a bad earth common issue again.
 

·
Registered
Joined
·
118 Posts
Just a random thought have you locked and unlocked the car a couple of times since you reconnected the battery? Mine does a weird thing sometimes when I disconnect the battery it won't start until I've done this. I must admit I did massively panic the first time it did to me!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Hello,

Rear light was a Bulb, the ignition fuse had some filth stuck in it which when I cleaned up it started fine. I have ordered a blanking plate for the EGR which I hope will resolve the issues of the EGR being stuck open.

Now just the ABS fault. Still getting the ABS error as above.

Thanks,

S
 

·
Moderator
Joined
·
11,780 Posts
ABS unit on a 307 is behind the passenger wheel arch liner. It starts out with a plastic bag to protect it but over the years dirt and water will get in.
 
1 - 11 of 11 Posts
Top