Peugeot Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Driving home yesterday when out of the blue a engine fault, stop immediately flashed up on the screen, the car then went into limp mode. Pulled over and rang the breakdown company. His reader came up with this fault
Product Gadget Red Font Electronic device


Towed back to my local garage and is awaiting repair. It is a 2014 Allure 1.6D 115bhp, with 51000 miles on the clock. Is it unusual for an injector to fail at this mileage?
Any ideas on how much this is going to cost me?
 

·
Registered
Joined
·
331 Posts
Not uncommon for injectors to fail, probably cost you a few hundred pounds if it is.
If you plan on keeping the car a while you might want to get all of them sent off to an injector specialist to test them and then you know another is not going to fail shortly after.
 

·
Moderator
Joined
·
9,430 Posts
Continental injectors do fail. Your code is related to the electrical side of the injector being open circuit. It could be a damaged wire, corroded connector injector or ECU fault.

You need to see if there is power to the injector and wiring first as that's the cheap fix

If it is a failed injector I would swap just the one as its an electrical fault and not mechanical wear or similar

Sent from my SM-G965F using Tapatalk
 
  • Like
Reactions: dougan1963

·
Moderator
Joined
·
9,430 Posts
On a side note injector 1 is gearbox end

Sent from my SM-G965F using Tapatalk
 
  • Like
Reactions: dougan1963
1 - 6 of 6 Posts
Top