Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I've had my 307 hd 2.0 for 3 years now.

Ever since I had it, I get a intermittent loud buz/rubbing noise when braking just for a few seconds.
At the same time the brake pedal kicks back, if i release the pedal and press again, its fine.
This has only happened about 10 times since i've had it.

Its mostly happend at full lock, when reversing or going down a hill.

It's happened twice in the last few weeks in exactly the same location (going down at hill).
It scared me as I nearly went up the back of someone.

I took it to a local garage and they said my back disk are warped???
Does this sound like somethinig would happen with warped disk?
surely it would happen every time I brake.

I'm really stuck and don't know what to do. I don't have £200 to replace the disaksd if this isn't the issue.
 

·
Moderator
Joined
·
5,891 Posts
Sounds more like the common rear abs sensor gap issue to me. It a common fault and we'll documented on here with a guide on how to fix

Sent from my SM-G900FD using Tapatalk
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Thank you that sounds about right. Is there anything I can do to test this is actually the issue? I can never replicate it.
 

·
Registered
Joined
·
1,805 Posts
I had the exact same problem and I was certain it was the servo.

However, I replaced the rear discs and pads, wound back the pistons, watched a few bubbles spew out and the issue has gone. The discs weren't warped (only heavily corroded). It could be hydraulics or, as windy said, ABS.
 
1 - 4 of 4 Posts
Top