Peugeot Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi
I have a 2010 Peugeot 207 and the braking system faulty warning has come up on dash with stop on guages.
Error code is C1383 brake fluid level sensor short
I have changed the abs pump as previuosly the abs error was shown the abs lights have gone out.
The brake fluid is fine in the servo reservoir
Could the reservoir sensor stick as the fluid drained out when changing the abs or is there another level sensor in the abs or can anyone advise me what to do to correct the error.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
braking system fault

the unit was from a donor car that i drove into my workshop and there was only a anti polution fault displayed. This donor car has had a rear smash.

Roughly how do you bleed using a diagnostic i havent done that before
 

·
Registered
Joined
·
22 Posts
Discussion Starter #11
braking system fault

Thanks David
Spoke to my local garage that read the car for me says he has done this type of bleed to another cars but not peugeot. he is going to have a look at it on Monday. Is it only diagbox that can do this?.

Thanks for your help I will post the results Tuesday.
 
D

·
Guest
Joined
·
0 Posts
Thanks David
Spoke to my local garage that read the car for me says he has done this type of bleed to another cars but not peugeot. he is going to have a look at it on Monday. Is it only diagbox that can do this?.

Thanks for your help I will post the results Tuesday.
Any good diagnostic kit should do it.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
22 Posts
Discussion Starter #13
braking system fault

Quick question
I am considering purchasing pp2000 and diagbox software, what interface will I need and which version is best to buy?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #15
braking system fault

Hi Guys
Back on the brake issue. I bought diagbox and have read the fault the error is C1383 Brake fliud sensor fault.
The description says that the switch resistor value to high
would this be in the abs or reservoir.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #16
braking system fault

Many thanks guys for all your help
sorted the brakes it was just a proper bleed with diagbox. quite an amazing bit of kit would really like to know it inside and out. Does any body know where i can get a tutorial or manual
 

·
Registered
Joined
·
206 Posts
No guide since it is intended to be a 'manufacturer only' diagnostic toolkit.

Can you post the procedure for bleeding the brakes?
 

·
Registered
Joined
·
1 Posts
fault C1383

hi guys, i have a 2008 peugeot 207 1.4hdi, i recently had a 2nd hand ABS unit (ecu and pump) fitted and this fault is present and wont clear as is a current fault.
the fault was present in the beginning of all the ABS unit troubles and taught it was a fault triggered by the pumps failure,however i was wrong.
i have had the car in with a pug dealer to diagnose problem(a friend is a mechanic there) and i was told to replace the brakefluid reservoir as the sensor is built in......and the fault was still there, then it was suggested i replace the engine bay fuse box as corrosion is common fault
now as nice as the guys are in pug dealership, like most main dealer mechanics most are part replacement specialists, and have no ideas about how or why the problem exists and no possible solutions for me other than to start by replacing the cars wiringloom and work back from that... no other electrical problems or faults.
the fitting of the ABS pump and ecu coding were both done by a peugeot mechanic.
has anyone ever encountered this problem or does anyone have any suggestions as to cause or solution...all help greatly appreciated.



panel beater/spray painter by trade, 14 years exp in insurance approved repair center.were i did most of if not all mechanical repair work that was takin in so i may not be a qualified mechanic but i have a good working knowledge......just not good enough
 

·
Registered
Joined
·
870 Posts
if its the pressure switch, looks like its fed from the bsi (on the same plug as cigar lighter , clock etc)
so worth trying a bsi reset.
 

·
Registered
Joined
·
2 Posts
I have similar issues in my 2005 607 2,2petrol, a C1383-code with a filled reservoir. Previous owner had replaced a rear brake caliper, and the problem started then as I understood.

I replaced the reservoir with the sensor, and the codes were still present, and came back after wiping them with a diagnostic tool.

BSI-reset had no effect either.

My diagnostic too can not do bleed-procedures. Is there any other way to check it is about air in abs?

What systems is it that senses air in the abs? How could the fault code be so misleading in description?
 
1 - 20 of 21 Posts
Top